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10 
IMPRESS BEYOND THE BASICS 
Making interactive, non-linear slide shows 
and enhancing formatting 

 

LEARNING OUTCOMES 
In the first Impress tutorial you learned how to create and save a new presentation (the Screenbeans 

slide show). You saw a sample slide show (The Tudor Monarchs). You learned how to prepare an 

outline, you typed text for each slide, added clip art, and set timings. You added an effect to 

enhance the slide transition, you selected a color scheme, and may have even created a new 

background effect. You changed the printer settings so that you can print out handouts rather than 

just individual slides of your shows. 

For many classrooms and for most K-12 students, what you learned in chapter 9 is just fine; 

it’s all you need to know. But, if you're ready to take the next step and learn some more advanced 

skills with Impress, or if you teach computer-savvy students who want more challenging skills to 

master, this chapter's for you. 

Most Impress presentations you see in school or at work are what are called linear 

presentations. That is, each slide is designed to proceed one slide right after another. The first slide 

transitions to the second, which transitions to the third, and so forth. For many educational tasks, 

this is fine. 

But, what if... 

What if you want your students to create an interactive story, where, for example, younger kids 

could read on Slide One a story about a dragon, then choose, on Slide Two, any one of three 

possible places that the dragon could go? By clicking on the word "desert," the show would move 

to a slide describing what happens to the dragon in the desert. If the student clicks on the word 

"forest," a different slide sequence appears with another ending. The learner thus participates, not 

by simply clicking on slide after slide in one, linear direction, but by making choices that affect 

what slide comes next, thus making the presentation interactive and non-linear. 
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A more common application of non-linear Impress presentations is when reviewing knowledge—

for what you might call interactive Drill & Practice. This lesson will teach you how to do that. 

Teachers (and even older students) can create quizzes using Impress. In these slide shows, students 

are asked questions and then click on what they think is the answer. If the answer is correct, the 

show moves to the next question. If the student answers incorrectly, the show moves the student 

back to re-answer the question or, if the question is of the True/False variety, explains why the 

answer was incorrect before moving them on to the next step in the show. 

The movement from one slide to another is not one-way, not linear, but rather non-linear, the 

pathway through the show determined by the student's interaction with it. 

In this tutorial you will be introduced to the basics of non-linear interactive Impress slide 

shows, along with some more advanced formatting and impact-enhancing tools. Amongst the skills 

you will learn are: 

 Creating and using Master Pages to add slide controls to presentations 

 Using hidden slides 

 Formatting and enhancing graphics 

 Inserting sounds, clip art, movies, and hyperlinks 

  

A caveat before you begin: 

If you have not completed the tutorial in Chapter 9 but feel fairly comfortable with the basics of 

Impress, feel free to tackle this chapter. If you are not sure you know the basics of Impress, 

however, skim Chapter 9 to make sure you're ready to proceed. Good luck! 

 

10.1 CREATING A MASTER PAGE TO ADD SLIDE CONTROLS TO AN 
EXISTING PRESENTATION 

Creating Slide Controls 

Slide Controls (otherwise known, in LibreOffice speak, as Interaction…) are buttons or objects 

that you insert onto a slide or slides to tell Impress, by clicking on them, to advance from one slide 

to the next slide, or to the previous slide, or to the first slide, and so on (Fig. 10.1). 

 

Fig. 10.1 Interaction options 
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You’ll be learning all about these Interaction options in a bit. Meanwhile you have some business 

to take care of. 

Creating a standard set of Slide Controls is simple enough. The best way to do this is to create 

a Master Page Template which has on it the set of Slide Control buttons that you’ll be able to use 

for any presentation that you’ll be building, whether now or in the future. Follow these directions 

carefully. 

Open a new LibreOffice Impress Presentation document, and go to File > 
Save As… (Fig. 10.2) 

 

Fig. 10.2 Saving a Master Page Template 

In the Save As dialog box, navigate to your USB drive > Work Files for 
LibreOffice 5 > Data Files > Impress Documents 

Click on the down arrow at the end of the Save as type: data entry box (Fig. 
10.2 above) and, in the menu of file types that drops down, select ODF 
Presentation Template (.otp) 

Name the new document Slide Controls Template and click on Save 

In the new Impress presentation document you want to start with a Blank Slide layout. To view the 

various slide layouts available in LibreOffice Impress, you need to have them show on the right 

side of the Impress window. You also need to have access to the Drawing toolbar. 

In the View menu select Slide Layout then, in the View menu > Toolbars 
select Drawing 

Click on this down arrow to 

bring up the menu of file types 
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The Drawing toolbar will show at the top of the Impress window immediately under the Standard 

toolbar (Fig. 10.3). 

 

Fig. 10.3 Selecting the Blank Slide layout 

In the menu of Layout templates in the Properties pane on the right of the 
Impress window, select the Blank Slide layout (Fig. 10.3 above) 

Now you’ll use two of the Basic Shapes in the Drawing Toolbar (Fig. 10.3 above) to create a set 

of Slide Control buttons. You’ll end up with something like the set of Slide Control buttons 

illustrated in Fig. 10.4. 

 

Fig. 10.4 Different Slide Control styles for a typical presentation 

It’ll be easiest to do this with the Impress window at 100%. 

Make sure the Zoom tool at the bottom right corner of the window is set at 100% 
(Fig. 10.5) 

 

Fig. 10.5 Set the Zoom tool at 100% 

The Drawing toolbar 

Blank Slide 

layout 
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Now, in the drawing toolbar’s set of Basic Shapes, click once on the 
Rectangle, Rounded tool and slide the mouse pointer—which changes into 
a plus sign (+)—onto the slide (Fig. 10.6) 

  

Fig. 10.6 Rounded Square and Isosceles Triangle tools in the set of Basic Shapes 

Fig. 10.7 shows how the Slide Control button will look when you’re done with this step. 

 

Fig. 10.7 Finished Slide Control button 

Drag with the pointer to draw a Rounded Square about 1” square near the 
bottom center of the blank slide (Fig. 10.8) 

 

Fig. 10.8 Rounded Square Slide Control 

Click on this down 

arrow to bring up the 

set of Basic Shapes 

Isosceles 

Triangle 

Rounded 

Square 
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Now select any Color to Fill the Area of the Rounded Square, then select 
some contrasting Color for the Border (Line) (see Fig. 10.8 above) 

Click anywhere off the Rounded Square to deselect it  

Next, in the drawing tools set of Basic Shapes, click on the Isosceles Triangle 
tool (Fig. 10.6 on previous page) and drag with the pointer to draw a small 
triangle inside the Rounded Square 

Use the Rotate tool to rotate the triangle to the right 90 degrees to the right 
(Fig. 10.9) 

 

Fig. 10.9 The Triangle shape inside the Rounded Square shape 

Do you get the idea? If so, you now know how to create any buttons you want. Feel free to go 

ahead and complete the set of Slide Controls illustrated in Fig. 10.4 on page 296 above. But for 

the sake of this exercise (and maybe your sanity!), the author has completed the two sets of four 

buttons and saved them in the Impress Documents folder as a Master Page Template so that you 

can use them for the exercises that follow. 

Close the Slide Controls Template file 

Adding slide controls to an existing presentation 

For the sake of uniformity, you are going to work with a version of the Screenbeans presentation 

you will have developed in Lesson 9 (if you completed that lesson) and which has been recreated 

especially for this tutorial. 

In the LibreOffice top level menu click on Open File 

Navigate on your USB drive to the Work Files for LibreOffice 5 > Impress 
Files folder, then double click on the file Problems and Solutions to open it 

Rotate 

Tool 

Drag on one of the Orange 

handles to rotate the Triangle 

shape 90 degrees to the right 
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You’ll be making changes to the Problems and Solutions presentation. But before you start work, 

it’ll be a good idea to save this original version in your Data Files folder, thus preserving the 

original version in the Work Files for LibreOffice 5. 

Go to File > Save As…, navigate on your USB drive to the Work Files for 
LibreOffice 5 > Data Files > Impress Documents folder, then click on Save 

You're going to put Slide Controls on each of the slides in the Problems and Solutions presentation. 

The Title Slide will have two Slide Controls—one to go to the next slide and another to go to the 

last slide. The last slide will also have two Slide Controls—one to go to the previous slide and 

another to go to the start of the slide show. Every other slide will have all four of the Slide Controls. 

Fig. 10.10 shows you how the Title Slide will look after you've added the Slide Controls. 

  

Fig. 10.10 The Slide Controls on the Title Slide 

The Slide Controls you need are in the Slide Controls Template, so you need to open that file first. 

Navigate on your USB drive to the Work Files for LibreOffice 5 > Impress 
Files folder, then double click on Slide Controls Template to open it 

For the Problems and Solutions Title Slide you want just the last two of the Slide Controls—to go 

to the next slide and to go to the last slide (Fig. 10.11). 

 

Fig. 10.11 Selecting and copying the Slide Controls 

Slide Controls: 

Next Slide, Last 

Slide 

Select 

Tool 
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In the View menu select Normal View then, in the Drawing toolbar, click on 
the Select tool (Fig. 10.11 previous page) 

Now drag with the mouse to select just the two rightmost of the four Slide 
Controls (the two on the right—see Fig. 10.11 previous page), then hit Ctrl+c 
to copy those two Slide Controls to the clipboard 

Switch back to the Problems and Solutions presentation, which is already 
open on your screen, and hit Ctrl+v to paste the Slide Controls from the 
clipboard onto the Title Slide, then use the arrow keys on the keyboard (or 
drag them with the mouse) to slide the Slide Controls into position in the 
lower right hand corner of the Title Slide (see Fig. 10.10 on the previous 
page) 

If you’d like the slide controls to be larger or smaller, you can adjust the size any time you want 

by clicking on them and dragging on the handles. 

If the Slide Controls looks too large or too small to you, go ahead now and 
grab one of the handles and adjust the size to your satisfaction, then click off 
the controls to deselect them 

Save the presentation when you’re satisfied everything looks OK on this Title 
Slide 

You now have two professional-looking Slide Controls on the Problems and Solutions Title Slide. 

We’ll test them shortly. First, though, you’re going to put all four of the Slide Control tools on the 

next seven slides. 

Switch back to the Slide Controls Template 

As you did before, click on the Select tool in the Drawing toolbar and drag 
around all four of the Slide Control buttons to put the green handles around 
them, right click on the selected buttons and, in the context menu that pops 
up, select Copy 

Then right click on the selected Slide Controls and, in the context menu 
that pops up, select copy to copy the Slide Controls to the clipboard 

In the View menu select Normal View, and hit Ctrl+v to paste the four Slide 
Controls from the clipboard onto Slide 2 

Don’t click on the Slide Controls—you want the small green handles to stay 
around them; now use the arrow keys on the keyboard to slide the Controls 
into position, this time in the lower left hand corner of Slide 2 (Fig. 10.12) 

 

Fig. 10.12 Position the Slide Controls in the lower left hand corner of Slide 2 

Keep the green handles after you 

paste the Controls onto the slide 
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Copying the Slide Controls to the other slides 

Next, you're going to put the four Slide Controls on each of the next seven slides (Slides 3-9). You 

already have the Slide Controls on the clipboard, so all you have to do is paste them as a group, 

slide after slide. 

In the Slides pane on the left side of the window, click on Slide 3 to bring it up 
in Normal View, and press Ctrl+v to paste the buttons onto the third slide 
and use the arrow keys on the keyboard to slide them into place lower left on 
the slide as you just did for Slide 2 

Now go to each of the next six (6) slides (Slides 4-9) in the presentation and 
do the same 

Slide 10 needs only the first two of the Slide Control buttons, to go to the previous slide and to go 

to the first slide. 

Switch back to the Slide Controls Template 

As you did before, click on the Select tool in the Drawing toolbar and drag 
around the two leftmost of the Slide Control buttons to put the green 
handles around them, right click on the selected buttons and, in the context 
menu that pops up, select Copy 

In the Slides pane on the left side of the window, click on Slide 10 to bring it 
up in Normal View, and press Ctrl+v to paste the buttons onto Slide 10, then 
use the arrow keys on the keyboard to slide them into place lower left on the 
slide 

Better Save your work to this point, then switch back to Slide Sorter View to 
see how everything looks—should be much like Fig. 10.13 

 

Fig. 10.13 All the slides now have the Slide Controls 
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Adding an Acknowledgements Slide 

The Problems and Solutions presentation is missing one final slide—the Acknowledgements Slide, 

which should accompany any presentation where you use information or audio-visual material that 

is not your own (in the case of the Problems and Solutions presentation, the Screenbeans images 

must be credited to Microsoft). Adding a new slide to a presentation is easy. 

First, select View menu > Slide Sorter to switch to the Slide Sorter view 

You want the Acknowledgements Slide to be the last slide in the show, so, 
in the Slide Sorter View, right click immediately after the thumbnail for slide 
10 and from the pop up context menu select New Page (new slide) 

The layout for the new slide, as you can see, is the same as the layout for the previous 8 slides, 

namely a Two Content layout. But for the Acknowledgements Slide it will be best if it is a Title, 

Content slide layout (Fig. 10.14). 

 

Fig. 10.14 Selecting the Title, Content slide layout 

Your next task is to put the two Slide Control buttons for First Slide and Previous Slide on Slide 

11, now the last slide in the show. 

In the Slide Sorter View, make sure the new Slide 11 is selected then, in the 
View menu, select Slide Layout to bring up the menu of Slide Layouts (Fig. 
10.14) and, in the Layout menu, select the Title, Content slide layout 

Switch back to the Slide Controls Template 

As you did before, click on the Select tool in the Drawing toolbar and drag to 
select all four of the Slide Control buttons to put the green handles around 
them, right click on the selected buttons and, in the context menu that pops 
up, select Copy 

Switch again back to the Problems and Solutions slide show and double 
click on Slide 11 to bring it up in Normal View 

Press Ctrl+v to paste the four Slide Control buttons onto Slide 11, then use 
the arrow keys on the keyboard to slide them into place lower left on the slide 
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You only need the first two of the Slide Control buttons (the First and Previous Slide buttons), so 

you’re going to delete the rightmost two buttons (the Next and Last Slide buttons) 

Click on the Select tool in the Drawing toolbar and drag to select the two 
rightmost of the Slide Control buttons to put the green handles around 
them, then hit the Del(ete) key 

 

Fig. 10.14 Selecting just the two rightmost Slide Controls 

Now all you need to do is type the text onto this Acknowledgements Slide. 

Click where you see “Click to add Title” and, in the Title box, type 
Acknowledgements, then click in the Click to add Text box and, by way of 
Acknowledgements, type just the first TWO bulleted items you see in Fig. 
10.15 

   

Fig. 10.15 Final version of the Acknowledgements Slide 

After you type the line: Text Courtesy of Bernie Poole, hit Enter, then hit the 
backspace key to delete the bullet, press Enter again, hit backspace to 
Del(ete) the bullet, then type the last line: Hit Esc(ape) to end the 
presentation (Fig. 10.15 above) 
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Finally, drag across the three lines of text (the two bulleted items and the last 
item) to highlight them, right click on the highlighted text and, in the context 
menu that pops up, select Edit Style… 

In the dialog box that comes up on the screen, click on the Font tab and in 
the Size menu select the Font Size of 28 

Hit Ctrl+s to save this (almost final) version of the Problems and Solutions 
presentation 

Better Save your work to this point, then go to View > Slide Sorter View to 
see how everything looks (should be much like Fig. 10.16) 

 

Fig. 10.16 Current look of the Problems and Solutions show 

Your show is almost ready, but first you have to learn about hidden slides. 

 

10.2 USING HIDDEN SLIDES 
Hidden Slides are slides that will be bypassed, unseen by the user as he or she clicks through a 

presentation, unless the user clicks on a Slide Control that specifically sends them to the Hidden 

Slide. Best way to understand this is to create a hidden slide for yourself. 

Here are the steps to create a Slide Control on one slide which will take the user to a specific 

Hidden Slide in the Screenbeans slide show. 

In the Slide Sorter View, double click on Slide 2 (the Confusion Slide) to 
open it in Normal View 

Click to position the cursor right at the end of the text that you typed in the 
slide’s text placeholder (after the words …tougher than it really is.) 

Hit Enter to go to a new line, then type If you’d like to read a quote about 
problem-solving, click here:  
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Go back to Slide Sorter View (View > Slide Sorter), right click on Slide 2 
and, in the context menu, select New Page to insert a new slide (which will 
now become the new Slide 3) 

Immediately, Impress inserts a new empty slide right after the second slide in the show and you 

now have 12 slides in the show. 

Now, you want this to be a Title Slide layout, so, still in the Slide Sorter View, 
right click on the new Slide 3 and, in the context menu, select Slide Layout 
and, in the menu of slide layouts, click on the Title Slide layout 

You want this new slide to be a Hidden Slide. 

Right click on the new Slide 3 and, in the context menu, select Hide Slide 
(Fig. 10.17) 

 

Fig. 10.17 The Hide Slide icon in the Slide View toolbar 

Notice that now, in the Slide Sorter View, Slide 3 is screened out, which indicates that this is a 

Hidden Slide (Fig. 10.17). 

Double click on Slide 3 to open it in Normal View, then click in the Title 
placeholder on the new slide (where it says Click to add Title), and type the 
following quotation (including the quotes): “Quality is in the details.” 

Drag across the quote to highlight it, right click on the highlighted text and, 
in the context menu that pops up, select Edit Style… 

In the dialog box that comes up on the screen, click on the Font tab and in 
the Size menu select the Font Size of 48 

Click in the subtitle placeholder on the new slide (where it says to Click to 
add text) and type the following: Bernie Poole, Esq. 

The Hidden Slide with the quote is now complete. But it’s hidden, so you have to give Impress 

(and the user) a way to find it by creating a new Slide Control that links to it. 

The Hidden 

Slide is 

screened out 
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Go to View > Slide Sorter, double click on Slide 2 (the Confusion Slide) to 
make it the active slide in Normal View 

In the Drawing toolbar click on the Block Arrows icon and, in the Block 
Arrows menu, select the Notched Right Arrow shape (Fig. 10.18) 

 

Fig. 10.18 Notched Right Arrow basic shape 

Notice that the arrow pointer changes to a cross hair ( ). 

Without clicking the mouse button, roll the mouse cursor up over the slide and 
position the cross hair after the colon at the end of "If you’d like to read a 
quote about problem-solving, click here: " (Fig. 10.19), then hold down the 
left mouse button and drag to create the Slide Control button that you are 
going to use to link to Slide 3—the hidden slide 

  

Fig. 10.19 Placement of the Slide Control linking to the hidden slide (Slide 3) 

Let go of the mouse button when you're done—you can adjust the size and 
position of the button if you want by clicking on it and then dragging on the 
handles around the button 

Basic 

Shapes 
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While you have the button selected, right click on it and select Edit Style… 
from the context menu, click on the Area tab and select an Area (Fill) color 
of your choice, then click on the Line tab and select a Line color of your 
choice, then click on OK 

Now right click on the new button and, in the context menu that pops up, 
select Interaction… 

In the Interaction dialog box, click on the down arrow at the end of the 
Action at mouse click: data box and, in the drop down menu, select Go to 
page or object, then, in the list of slides that is displayed, click to select Slide 
3, then click on OK (Fig. 10.20) 

  

Fig. 10.20 Linking the new Slide Control to the hidden slide 

This new Slide Control provides a link from Slide 2 to the hidden Slide 3. When you run the show 

shortly and get to Slide 2, if you click on this Slide Control, you will go to Slide 3. But if you do 

not click on this Slide Control, Slide 3 will be bypassed because it is a hidden slide. 

You have to do one more thing to complete the content on the hidden slide (Slide 3). You need 

to put a Slide Control on Slide 3 to go to the next slide (Slide 4). Can you remember how to do it 

yourself? If so, go ahead; but if you need help, here are the steps to follow: 

Go to View > Slide Sorter and double click on Slide 2 to bring up the slide in 
Normal View, then, in the Drawing toolbar, click on the Select tool and drag 
to select the third of the four Slide Controls (the Slide Control to go to the 
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next slide), right click on it, then, in the context menu that pops up, select 
Copy 

Go to View > Slide Sorter and double click on Slide 3 to bring up the slide in 
Normal View, and press Ctrl+v to paste the Slide Control onto the hidden 
slide 

While the button is still selected, use the arrow keys to move it over and down 
to the lower right corner of the slide, then drag on the green handles to make 
the Slide Control at least twice its size (big as you want as long as it doesn’t 
cover “Bernie Poole, Esq.”—Fig. 10.21) 

 

Fig. 10.21 The repositioned and resized Slide Control on the Hidden Slide 

In the Interaction dialog box, click on the down arrow at the end of the 
Action at mouse click: data box and, in the drop down menu, select Go to 
page or object, then, in the list of slides that is displayed, click to select Slide 
4, then click on OK 

Save all the good work you’ve done so far, then Run the Problems and 
Solutions slide show from the start (Slide Show menu > Start from first 
slide), trying out every slide, including the Slide Controls that you just created 
for the Hidden Slide 

 

10.3 ANIMATION SCHEMES 
Impress Animation is a way of bringing objects, such as text and pictures, to life on the screen, 

controlling and sequencing how text and other slide objects emerge onto the screen during a 

presentation—sliding in from the right or left, or fading in, and so forth. Let's try some of the 

Impress Animations now, using the Screenbean figures as our models. 
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The Screenbean figure must be selected in order to apply animations and 
other effects to it, so, go to View > Slide Sorter and double click on Slide 2 
(the slide with the Confused Screenbean) to bring up the slide in Normal 
View, and click to select the Screenbean figure (green handles surround it) 

Right click on the Confused Screenbean figure and, in the View menu 
select Custom Animation 

This brings up the Custom Animation pane on the right side of the Impress window (Fig. 10.22). 

 

Fig. 10.22 The Custom Animation pane 

Click on the green plus sign/cross to bring up a menu of built-in LibreOffice 
animations (Fig. 10.22) 

For the Screenbean figure on Slide 2, in the menu of built-in LibreOffice 
Effects select the first option: Appear then, in the Start entry box, select After 
Previous, and in the Duration entry box select 3 seconds (Fig. 10.22) 

To check out the animation, go to the Slide Show menu > Start from current 
Slide and watch as Impress gives you a demo of the effect 

Notice that the Screenbean figurine finally appears after the text with a delay of 3 seconds. 

Go to View > Slide Sorter and double click on Slide 4 to bring up the slide in 
Normal View and take a few minutes to preview a few other Animation 
Effects to get a feel for what is available 

Click on this green plus 

sign/cross to bring up a menu of 

built-in LibreOffice animations 
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When you are done experimenting on Slide 4, work your way from Slide 4 to 
Slide 10 and, for each Screenbean figure, select any one of the Effects you 
like, then in the Start section select the option to Start > After Previous, and 
select a Duration of anywhere from 1 to 3 seconds 

After selecting animations for all the Screenbean figures, Save the 
presentation, then go to the Slide Show menu > Start from current Slide and 
check out the Problems and Solutions presentation once again 

Pretty cool. So Impress makes it easy for you to experiment with different schemes, try them out, 

remove them if you don’t like them, and start over—all part of the design process. 

You can change any sequence, and you can also sequence the items to come onto the screen 

all at once, and so forth. There will be occasions when you will want to alter the sequence because, 

for example, you may decide that you want to talk about one topic ahead of another. Also, you 

may want the presentation to be presented as a running display in a conference room or in the 

lobby of a building. 

You also can determine the time you want each item to stay on the screen before the next 

animation is to come up. To do this, you would use the Slide Show > Rehearse Timings tools. It 

is beyond the scope of this tutorial to dwell further on this topic, but you should find the time to 

play around with the tools available to you so that you can become an expert in the use of this 

excellent teaching tool. 

Bear in mind that it’s not a good idea to apply Animation Schemes everywhere, on all the 

slides. Animations are best used sparingly, to highlight specific ideas, or to spice things up in a 

presentation. But too much spice can overwhelm a presentation and take away from its enjoyment 

or effectiveness. 

In the File menu select Close to close the Problems and Solutions 
presentation 

 

10.4 INTERACTIVE IMPRESS AT WORK 
Let’s start by looking at an example of an interactive Impress presentation. 

In the File menu select Open File and navigate (Browse) on your computer to 
your USB drive > Work Files for LibreOffice 5 > Impress Files folder, then 
double click to open the Mammal Test presentation 

You’re going to examine the Mammal Test interactive presentation which has been prepared for 

you and which will demonstrate the various features of what makes a presentation interactive and 

non-linear. 

In the Slide Show menu select Start from first Slide to view the presentation 

Follow the directions to move through the slides—be sure to click on the  
answers when indicated 

Answer at least one question incorrectly so you can see how the 
presentation takes you back to re-answer a question should you get it wrong 

Make sure your speakers are turned up so you can hear the sound, and notice 
the clip art and animations that are added to this show 
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Features to look for in the demonstration presentation 

General layout of an interactive presentation used for assessing knowledge 

Think of a test in your classroom. You start with a title on your test, so the students know what 

subject matter the test is on and who wrote it. Then you have an introduction, which might further 

define the subject matter for the test. Alternatively, if used as a review, the introduction might 

summarize the concept being tested. 

A good interactive slide show thus begins with a title and an introduction Slide (Fig. 10.21). 

  

Fig. 10.21 Title and Introduction Slides 

You then move to the set of directions which tell the user how to complete the test. The test 

questions follow right on after the directions. 

An effective interactive slide show should have a Directions Slide because a good teacher 

never assumes that all the students know how to take a particular test. After the directions come 

the question slides, which contain the questions themselves and the options for answers (Fig. 

10.22). 

 

Fig. 10.22 Directions and Question One Slide 

An interactive Impress presentation has the same elements as any Impress presentation, with one 

significant difference: it has question slides and feedback slides. In your class, you grade papers 

and return them, giving the students feedback on their answers. 



Lesson 10: Impress Beyond the Basics 

 329 

So, in the Mammal Test slide show, we have feedback slides that tell the user "You're Right" or 

"Sorry. Try Again." (Fig. 10.23).  

  
Fig. 10.23 Question and Feedback Slides 

Lastly, in an interactive Impress presentation it's appropriate to have a Concluding Slide which 

tells the students they’re done, followed by an Acknowledgements Slide (Fig. 10.26). 

  

Fig. 10.24 Ending and Acknowledgment Slides 

In this way, you set good precedent for citing sources, and you also clue your audience to the fact 

that it's over! We'll talk more about the layout of an interactive Impress slide show as you begin 

creating your own. 

Slide Controls and Hyperlinks 

In order to move outside the linear box of traditional Impress presentations, we've used Slide 

Controls and Hyperlinks. Slide Controls, as you know, are the buttons that control the user’s 

progress as they work through the presentation. In the case of the Mammal Test presentation, they 

let you either move on to the next question or re-answer the previous one. Slide Controls were 
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discussed in Section 10.1 of this chapter, but we'll pay special attention to them in the subsequent 

activities.  

An Impress hyperlink takes you directly from one place to another: if you are on the Web, the 

hyperlinks take you from one Web site to another, or from a website to your email program. If you 

are in an Impress presentation, the hyperlink might take you from a slide to your E-mail program, 

or from one slide in your presentation to another, or from a slide in your Impress presentation to, 

say, a page on the Web. 

Notice the transitions and animations in the Mammal Test presentation. The presentation has 

a simple, clean style—no excessive bells and whistles; just enough to keep the students’ attention. 

In Lesson 9 and earlier in this lesson, you practiced using different effects for Slide Transitions 

and you were introduced to Animations. 

These are certainly valuable tools that engage your viewers and help to keep their interest. But 

everything has a time and a place, and in a testing situation, too many bells and whistles may, 

indeed, be an unwanted distraction. 

So much for an overview of using an interactive Impress presentation. It's time to create your 

own interactive quiz. 

One final word before you begin: if you are a practicing teacher using this tutorial, and you 

consider yourself an experienced user of the computer, why don’t you use an existing quiz of your 

own, or even create one from scratch, a quiz based on your grade level or subject matter using the 

upcoming steps as your guide? Experienced computer-using teachers should have little trouble 

doing this. But if you're even the least bit unsure about how an interactive show works, stick with 

the mock test below for your first try. Then practice it later with your own curriculum! 

Click ESC to exit the slide show, then close (File > Close) the Mammal Test 
presentation when you are ready to continue with the tutorial 

 

10.5 BUILDING AN INTERACTIVE, NON-LINEAR PRESENTATION 
You are going to use Impress to prepare a Class Test about the U.S. states and capitals, which will 

give you the experience to prepare more detailed interactive tests on your own. 

The LibreOffice introductory window should still be open on your screen, so go 
to Create > Impress Presentation to start a new slide show 

You should always immediately save a new document; this allows you to give the document a 

name, as well as the opportunity to save it in a location you want on your disk drive (so that can 

more easily find it again later!). 

Go to File > Save As, navigate to your USB Drive > Work Files for 
LibreOffice 5 > Data Files > Impress Documents folder 

Name new presentation States and Capitals Quiz, and click on Save 

It is usually a good idea to create the text outline for your slides before you select a template for 

your design theme, slide transitions, animations and so forth. This is because different templates 

have different slide layouts (bigger title boxes, less room for bulleted lists, and so on). So you will 

want to get a feel for what will be the text on each slide, before you proceed with design 

considerations. 
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This brings to mind a good rule of thumb when creating anything that is designed to provide 

information for the purpose of effective communication: Substance Before Style! Or, to put it 

another way, Content Counts! Keep this in mind when developing any Impress presentation. 

Let's get to work. 

Title Slide, Intro Slide and Directions Slide 

Fig. 10.25a-c illustrates the content you will be entering for the first three slides. Follow the 

directions on the next page to complete this first part of the exercise. 

 

Fig. 10.25a Content for Slide 1 

 

Fig. 10.25b Content for Slide 2 

 

Fig. 10.25c Content for Slide 3 
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In Lesson 9 you learned how to plan a presentation by entering an outline of the text in the Outline 

View of a slide. For this presentation, however, you’ll enter the text directly onto each slide using 

the Normal View. 

Entering data directly onto slides can be tricky because you have to be careful how you use the 

Enter and Tab keys, so follow the directions carefully. 

The default layout for the first slide in any new Impress show is always a Title Slide (Fig. 

10.26). 

 

Fig. 10.26 The Title Slide layout 

In the View menu select Normal. 

Notice that the Normal View of a slide includes a Slides pane on the left side of the window in 

which you’ll see a thumbnail of each of the slides, starting with the Title Slide (Fig. 10.26). On the 

right side of the window you should see the Properties pane with thumbnails of the different 

layouts you can use for the slides (Fig. 26 above). 

If you do not see the Properties pane, here’s what you need to do. 

In the View menu select Slide Layout (the Slide Layout thumbprints are 
included in the Properties pane) 

For the first Title slide, in Normal View, click inside the Title box and type U.S. 
States and Capitals Quiz, then hit Ctrl+Enter to move the cursor down to the 
sub-title box, type By ______ (type your name in the blank) and hit the Enter 
key 

The Properties 

pane should be 

showing on the 

right side of the 

window 

This is the 

Slides pane on 

the left side of 

the window 
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The sub-title By _______ (your name) should now be in the sub-title box of your first slide. 

In the Insert menu select Page Number… to bring up the Header and Footer 
dialog box (Fig. 10.27) 

  

Fig. 10.27 The Header and Footer dialog box 

In the Header and Footer dialog box make sure the Slides tab is selected, 
then click to put a check mark/tick next to Date and Time, click on the radio 
button next to Variable and, in the drop down menu of date/time formats, 
select the format indicated in Fig. 10.27 on the previous page 

Put a check mark/tick next to Slide number, then click on Apply to All 

In the Slides pane on the left (Fig. 10.26 on the previous page), right click on 
Slide 1 and, in the context menu, select New Page to start a new slide 

The default Slide Layout for the first slide in a presentation is Title slide layout, but you want a 

Title, Content slide layout for Slide 2. 

You want the Title, Content layout for Slide 2 and subsequent slides, so, in the 
menu of Slide Layouts in the Properties pane, click on the thumbnail for 
Title, Content layout 

Get to know the Keyboard Shortcuts 

Ctrl+Enter is a keyboard shortcut that moves the cursor to the next text box on a slide. You hit 

Enter only when you want to advance to the next line inside the text box where you’re typing text. 

As you type on the slide, the Properties pane shows various formatting tools, such as left, 

center and right alignment for text (Fig. 10. 28 on the next page). Refer to these when necessary 

as you go along. 
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Refer back to Fig. 10.25b and 10.25c on page 316 above as you type the 
information for the next 2 slides, then Save your work 

Question and Feedback slides 

Next you are going to type the five Question and Feedback slides—Slides 4-8 (Fig. 10.28). 

 

Fig. 10.28 Content for Slides 4-8 

If you already have completed the introductory Impress tutorial (Lesson 9), you should be able to 

carry out the following tasks without step-by-step help. However, in case you need guidance, here 

are the directions for the first test question slide. 

Stay with the LibreOffice default font (Liberation Sans), and the default font sizes, too. After 

you’ve typed up the text for the slides, feel free to change the font to one of your personal 

preference, but only do that after you’ve typed the text for all the slides. You may notice that the 

author’s preference is for Comic Sans MS, which appears to work best for text objects. More on 

that anon when you come to deal with the sets of Answers for each of the Questions. 

Here are the directions for Slide 4. 

In the Slides pane on the left of the window, right click on the thumbnail for 
Slide 3 and from the context menu select New Page 

Next click in the Title box for the new Slide 4, in the Properties pane click on 
the Left alignment icon, and type the title Question One, then hit Ctrl+Enter 
to skip to the text box below the Title box 

Before you start typing the first question (Which is the capital of Texas?), hit 
the Backspace key to remove the Bullet at the beginning of the line, then type 
the question: Which is the capital of Texas? 

Repeat these same directions to complete the entries now for Slides 5 and 6, 
then Save your work. 
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Now that the Titles and Questions are on the question slides, you next need to create, and type the 

content for, the two feedback slides: You're Right! (Slide 7) and Sorry. Try Again (Slide 8)—see 

Fig. 10.28 above. 

In the Slides pane on the left of the window, right click on the thumbnail for 
Slide 6 and from the context menu select New Page to start a New Slide 
(Slide 7) 

You need to change the layout of the feedback slides, because all you need on them for now is a 

Title box. Fortunately, Impress has a layout called Title Only. 

In the Slide Layout menu on the right side of the window, select the layout 
for Title Only 

Now go ahead and, in the Title box for Slide 7, type You’re Right! 

Create a new Slide 8, which will again have a Title Only layout, and, in the 
Title box for Slide 8, type Sorry. Try again.  

Use Copy & Paste to save time 

Next, you must place a copy of these two feedback slides after each of the other question slides. 

Copy & Paste is the easiest way to do this. 

In the Slides pane on the left of the window, click on Slide 7, hold down the 
Shift key and at the same time click on Slide 8 to select both slides at once, 
then hit Ctrl+c on the keyboard to copy these two slides to the clipboard 

Now, with Slides 7 and 8 on the clipboard, right click between Slides 4 and 
5 and in the context menu select paste 

The two answer slides are now repeated between slides 4 and 5; so what 
was originally Slide 5—Question Two—will be bumped to Slide 7 (Fig. 10.29) 

  

Fig. 10.29 Adding the Answer slides between each of the Question slides 

Was Slide 5 Was Slide 6 
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Now do the same thing to Paste the Answer slides right after what will now be 
Slide 7 (between Slides 7 and 8), then Save your work once more 

The States and Capitals Quiz Impress now has 12 slides—the three introductory slides and the nine 

question and answer slides. For any Impress show, it is important to have a slide that signals the 

end of the main body of content (such as the end of testing in the case of our show). Impress 

presentations that end abruptly can be disconcerting to a viewer. Also, it is important to give credit 

where credit is due. So, at the conclusion to most any slide show you should include an 

Acknowledgements Slide. These are your next two tasks. 

Create two new slides (Slide 13 and Slide 14); Slide 13 will be Title Only 
layout and Slide 14 will be Title, Content layout 

Type the content for Slides 13 and 14 as illustrated in Fig. 10.30, then Save 
your work again 

  

Fig. 10.30 End of Test and Acknowledgement Slides 

It might be a good idea to take a break at this point in the tutorial. But if you feel up to it, feel free 

to proceed directly to the next section, Section 10.6 on the next page. 

 

TIME FOR A BREAK? 

FEEL FREE TO TAKE ONE… 

THIS MIGHT BE ENOUGH FOR ONE DAY! 
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10.6 MAKING THE PRESENTATION INTERACTIVE 
You are now going to tackle the two trickiest steps in this lesson. They are: 

1. Creating four hyperlinking Slide Controls on each of the three Question slides which the 

user will click on to indicate his or her answer to the question. 

2. Creating a Slide Control on each of the six Feedback slides that will hyperlink to the 

appropriate Question slide. 

Creating Text Objects for the Slide Controls on the Question slides 

A Text Object is text that has been converted into a LibreOffice Object so that it can be used as a 

hyperlink and can also be animated, just the same as any image. 

Let’s do the first Question slide together (Slide 4), and then you’ll know what to do for the 

other two question slides (Slides 7 and 10). 

Go to View > Slide Sorter and double click on Slide 4 (Question One) to 
open it in Normal View 

In the Drawing toolbar at the top of the window (right under the Standard 
toolbar), click on the Rectangle tool to select it, then draw a rectangle about 
½” below the Question and about 3” wide, and more or less centered on the 
slide (Fig. 10.31) 

 

Fig. 10.31 Draw a rectangle about ½” down from the Question 

With the rectangle still selected, hit Ctrl+c to copy it, then hit Ctrl-v to paste 
the copy back onto the slide (for reasons best known to itself, LibreOffice 
pastes the copy directly on top of the original, so you’re not aware of anything 
having been done—but believe me, the copy is there!) 

With the handles still showing around the rectangle shape, use the arrow keys 
to slide the copy down below the original, so that now you have two identical 
rectangles on the slide (Fig. 10.32) 

 

Fig. 10.32 The two identical rectangles on Slide 4 
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Now hold down the Shift key while you click on the first rectangle so that now 
both shapes are selected, hit Ctrl+c to copy them, then hit Ctrl-v to paste the 
copies back onto the slide 

Once again, use the arrow keys to slide the copies down below the originals, 
so that now you have four identical rectangles on the slide (Fig. 10.33) 

 

Fig. 10.33 The four rectangles ready for processing into Text Objects 

At this stage it will be a considerable time saver if you copy the four rectangle shapes and paste 

them onto the other two Question slides—Slide 7 and Slide 10. 

Hold down the Shift key while you click on each of the rectangle shapes so 
that now all four shapes are selected and hit Ctrl+c to copy them 

Go to View > Slide Sorter and double click on Slide 7 to bring up the slide in 
Normal View, then paste the four rectangle shapes directly onto the slide 

Switch to Slide 10 and do the same, then Save your work 

Now for the conversion of the Rectangles into Text objects. We’ll do this together for Slide 4, 

then you can follow the same steps yourself to convert the rectangles on Slide 7 and Slide 10. 

1. Go to View > Slide Sorter and double click on Slide 4 to bring up the slide in 
Normal View, then double click on the first rectangle and type the first 
Answer: Houston 

2. Double click on Houston to highlight it and, in the Properties pane > 
Character toolbar (Fig. 10.34), increase the Font Size to 28 pt and change the 
font to Comic Sans MS or any other font you like 

 

 
Fig. 10.34 Character tools in the Properties pane 
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3. Next, double click on the second rectangle and type the second Answer: 
Dallas, then double click on Dallas to highlight it and, in the Properties pane 
> Character toolbar, increase the Font Size to 28 pt 

4. Next, double click on the third rectangle and type the third Answer: San 
Antonio, then triple click on San Antonio (it’s two words) to highlight it and, in 
the Properties pane > Character toolbar, increase the Font Size to 28 pt 

5. Finally, double click on the fourth rectangle and type the fourth Answer: 
Austin, then Double click on Austin to highlight it and, in the Properties pane 
> Character toolbar, increase the Font Size to 28 pt 

Better Save your work again and now follow the same five (5) steps above to enter 
the Answers for Slides 7 and 10 

The answers for Slide 7 are as follows: California 

 Alaska 

 Texas 

 Rhode Island 

The answers for Slide 10 are as follows: Hawaii 

Florida 

California 

Mississippi 

Over to you. Don’t forget to save your work when you’re done. 

Hyperlinking the Text Objects to the appropriate Feedback Slides 

Now you must revisit each of the four Answers on the three Question slides to tell Impress which 

slide the Answer should hyperlink to after it is clicked. This is where it gets tricky. If the answer 

the student chooses for each question is correct, the hyperlink must send him or her to the You’re 

Right! Slide, and move on to the next question; otherwise it must send him or her to the Sorry. 

Try again. Slide, and return him or her back to the original question to try again. 

If you’ve never done anything like this before, the best way to understand is to do it. 

Go to View > Slide Sorter and double click on Slide 4 to open it in Normal 
View, then right click on the Houston button and, in the Context menu, 
select Interaction… to bring up the Interaction dialog box (Fig. 10.35). 

 

Fig. 10.35 The Interaction dialog box 
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In the Action at mouse click entry box, click on the down arrow to bring up 
the menu of options and select the option to Go to page or object 

Click on Slide 6 and click OK  

Why Slide 6? Because Houston, the answer we just converted into a hyperlink, is not the capital 

of Texas. So we want the student to be presented with the feedback slide that says the answer is 

wrong. 

Repeat these steps for the answers Dallas and San Antonio (also wrong 
answers)  

Now, highlight Austin (the correct answer)  

Since Austin is in fact the capital of Texas, we want to link that answer to the feedback slide (Slide 

5) that indicates that the correct answer has been selected. 

Right click on the Austin button and, in the context menu, select 
Interaction…, then in the Action at mouse click entry box, click on the down 
arrow to bring up the menu of options and select the option to Go to page or 
object, and finally click on Slide 6 and click OK 

Adding a Slide Control button to each of the Answer slides 

Now you need to put the correct Slide Control button on each of the Question One Answer slides 

(Slides 5 and 6). 

Go to View > Slide Sorter and double click on Slide 5 to bring up the slide in 
Normal View then, in the Drawing toolbar, click on the Block Arrows icon to 
bring up the set of Block Arrow shapes (Fig. 10.36) 

  

Fig. 10.36 The Chevron shape in the set of Block Arrows shapes 
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Click to select the Chevron shape, then draw a nice big Chevron shape 
towards the lower right side of the slide (Fig. 10. 37) 

 

Fig. 10.37 The Slide Control on Slide 5 

Right click on the Chevron shape and, in the context menu, select Area… 
(Fig. 10. 38) 

 

Fig. 10.38 Choosing a Color for the Slide Control 

Click on the Area tab and, in the drop down menu of colors, select any color 
you like for the Chevron-shaped Slide Control 

Next you need to put a chevron-shaped button on the Wrong answer slide (Slide 6). Easiest way 

to do this is to copy and paste the button you just created for Slide 5. 

On Slide 5, click on the Slide Control to select it and hit Ctrl+c to copy it, 
switch to Slide 6 and hit Ctrl+v to paste the button onto Slide 6 

You want this Wrong answer button to point back to Question One, so you need to flip it 

horizontally. 

Right click on the Slide Control and, in the context menu, select Flip > 
Horizontally, then Save your work before you proceed 

Now you need to select the correct hyperlink for these two new buttons. A hyperlink is a tool for 

linking to another place in the same document (in our case to another slide in the same slide show) 

or to an entirely different document. For the button on the correct answer slide (Slide 5) you want 
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to send the student on to the next question (Question Two), which is Slide 7; but for the button on 

the wrong answer slide (Slide 6) you want to send the user back to Question One (Slide 4). 

Go to View > Slide Sorter and double click on Slide 5 to bring up the slide in 
Normal View, right click on the Chevron shaped Slide Control and, in the 
context menu, select Interaction… and hyperlink (click on Go to page or 
object) to Slide 7 

Go to View > Slide Sorter and double click on Slide 6 to bring up the slide in 
Normal View, right click on the Chevron shaped Slide Control and, in the 
context menu, select Interaction… and hyperlink (click on Go to page or 
object)  to Slide 4 

Time to make sure each answer on the Question One slide, and each button on the Answer slides 

is correctly hyperlinked by testing each of them in turn. 

Go to View > Slide Sorter and double click on Slide 4 to bring up the slide in 
Normal View, then in the Slide Show menu select Start from current Slide 

Click on each of the possible answers one-by-one, make sure they send you 
to the correct Answer slide, then make sure the chevron-shaped Slide 
Control on each of the answer slides sends the user forward or back to the 
correct question 

Everything AOK? If not, fix any errors—hopefully there won’t be any, but you never know. 

Breathe a sigh of relief if all went according to plan. 

Now, follow the same series of steps (if you need help, the directions start on Page 325 
above--Adding a Slide Control button to each of the Answer slides) to add the Slide Controls 
with hyperlinks for Slides 7 thru 9 (the second question, where the correct answer is 
Alaska), and Slides 10 thru 12 (the third question, where the correct answer is Hawaii) 

Adding Slide Controls to the remaining slides (Slides 1 thru 3 and Slides 13 and 14) 

You’re going to need Slide Controls on Slides 1 thru 3, and also on Slides 13 and 14. You should 

be good at this now, but just in case here are the steps you need to take. 

In Slide Sorter View, double click on Slide 1 to open it in Normal View, then, 
in the Drawing toolbar > Block Arrows icon, click on the Chevron shape and 
draw a small Chevron in the lower right corner of the Slide window (Fig. 
10.39) 

 

Fig. 10.39 Slide Control to go the Next Slide 
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Right click on the button, then, in the context menu, select Interaction… and 
select the Action at mouse click option to Go to next slide 

While you’re at it, hit Ctrl+c to copy the Slide Control to the clipboard 

That’s all you need on the first slide. But you need the same button on Slides 2, 3, 13, and 14. 

Fortunately, you have it copied to the clipboard, so… 

In Slide Sorter View, double click on Slide 2 and paste the Slide Control on 
the slide 

Do the same for Slides 3, 13 and 14 

On Slides 2, 3, and 14 you need a second Control button to Go to previous slide. 

In Slide Sorter View, double click on Slide 2 again, right click on the Slide 
Control in the lower right corner, copy it, then paste it (Ctrl+v) 

Right click on the Slide Control again, and, in the context menu select the 
option to Flip > Horizontally, then use the arrow keys on the keyboard to slide 
this second Slide Control to the left (Fig. 10. 40) 

 

Fig. 10.40 The second Slide Control button in position on Slide 2 

Right click on this second Slide Control, copy it, then paste it (Ctrl+v) onto 
Slides 3 and 14 

Your patience is appreciated. Hey, for some people, this is their idea of fun! I hope you feel the 

same. One last task at this stage of the Tutorial. The last slide, Slide 14, has a Slide Control to go 

to the next slide, but there is no next slide. So you have to change the Action on mouse click to 

Exit Presentation. 

In Slide Sorter View, double click on Slide 14 if it is not already in Normal 
View, right click on the rightmost Slide Control in the lower right corner, 
select Interaction... from the pop up context menu, and change the Action on 
mouse click option to Exit presentation 

Save your work before you proceed (and maybe take a break…) 
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Making the Text Object backgrounds invisible 

On Slides 4, 7, and 10, those Blue rectangles behind the multiple choice answers are unnecessary. 

It’s easy enough to get rid of them at this stage, though they were necessary while you were 

developing the Text Objects and hyperlinking them. Let’s make them invisible now. 

In Slide Sorter View, double click on Slide 4 and right click anywhere on 
the first blue rectangle, then, in the context menu, select Line… to bring up 
the Line dialog box (Fig. 10.41) 

  

Fig. 10.41 The Line dialog box 

In the Style drop down menu, select – none – to remove the border around 
the rectangle shape, then click on OK and, still on Slide 4, right click anywhere 
on the first blue rectangle, then, in the context menu, select Area… to bring 
up the Area dialog box (Fig. 10.42) 

  

Fig. 10.42 The Area dialog box 
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In the Area dialog box, click on the Transparency tab, then in the 
Transparency mode section make sure the radio button next to 
Transparency is checked, and set the Transparency percentage to 100%, 
then click on OK 

Houston appears as plain text, but it’s actually a Text Object which holds a hyperlink (Fig. 10.43) 

 

Fig. 10.43 Text Objects with invisible backgrounds 

Now do the same thing to the other 11 Text Object multiple choice answers 
on Slides 4, 7, and 10, then Save your work when you’re done 

Forcing the user to click on a Slide Control to advance to another slide 

For the feedback slides such as the one illustrated in Fig. 10.30 above, we must make sure that the 

user can only proceed from one slide to another by clicking a Slide Control. As it is, when the user 

clicks the mouse anywhere on the slide, the show will advance to the next slide whether it’s 

supposed to go there or not. 

So here’s how you give the user no option but to click on a Slide Control in order to proceed. 

Go to View > Slide Sorter View, hit Ctrl+a to select all the slides, then in the 
Slide Show menu select Slide Show Settings… to bring up the Slide Show 
Settings dialog box (Fig. 10.44) 

 

Fig. 10.44 The Slide Show Settings dialog box 

Each of 

these Text 

objects is 

a 

hyperlink 

to another 

slide in 

the show 
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Click to select the Radio button next to Range > All slides and in the Options 
section make sure you only have check marks next to Mouse pointer 
visible and Animations allowed—NOTHING else should be checked! 

Especially make sure there is NO check mark/tick next to Change slides by 
clicking on background 

Save your work again 

 

10.7 FORMATTING YOUR PRESENTATION 
If you have followed this chapter step-by-step, you’ve just now finished testing your slide show. 

You’ve covered all the nuts and bolts of the show. Now it is time to improve the appearance of the 

show and make your U.S. States and Capitals quiz a bit more attractive.  

Selecting a Master Page 

LibreOffice makes it easy to select a background, font type and style, and color scheme for your 

presentation. All these features are combined into what Impress calls a Master Page. 

Earlier we mentioned that you could start your new presentation by picking the Master Page 

before even typing in the text. Well, as we already discussed, sometimes it is best to wait to select 

a Master Page until you have an idea of where text should be on the slides and how much text is 

on each slide. Some Master Pages, for example, have graphics that take more space on the slide 

than others and might make it hard to read your text. 

In the Slide Sorter View, hit Ctrl+a to select all the slides, then click on the 
Master Pages icon on the right edge of the Impress window (Fig. 10.45) 

 

Fig. 10.45 The Master Pages icon 
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Click on any of the Master Page icons in the menu and wait as Impress 
propagates the design to all the slides in the Slide Sorter View 

Preview several of the available Master Pages before deciding which one 
you’d like to use  

The Master Page chosen for the demonstration show, which is used in the illustrations below, is 

called AbstractYellow and has the advantage of needing little or no adjustments to be made to the 

slides after the Master Page is applied. But feel free to use whichever of the Master Pages you 

want for your presentation.1 You can always change it later. 

Indeed, you can change everything and anything once you have the text for each slide in place. 

You can change the text, too. With Impress (or computer apps in general) nothing is chiseled in 

stone until you say so! And even then, you can still change your mind. 

What you need, above all, when working with a computer app such as Impress is PATIENCE. 

If you’re always in a hurry, you’d better be either very talented or lucky to do good work. But if 

you’re patient, Impress will help you to do the best job you’re capable of doing, that’s for sure. 

When you’ve decided which Master Page you want, Save the presentation 

Tips on color choices for printing 

Lesson 9 covered the topic of printing Impress presentations, but this is a good time to mention 

editing your background for how it will appear on paper. Many of the Master Pages are attractive 

to look at; however, when you print handouts or slides in black ink, the dark backgrounds make 

some text hard to read. So, if you plan to print out your show, choose a lighter background for all 

the slides. Then, when you are ready to print, in the Print Settings section, click on the Color button 

and, in the Color options, select Grayscale. This reduces the background to more or less plain 

white with black text, making it easier to read than color. It will also save a lot of money on the 

ink cartridges for the printer! 

Creating customized, self-designed Master Page Templates 

For most users, the Master Pages provided by Impress are more than sufficient to meet their design 

needs. Other Master Pages can be accessed online. But if you prefer to create your own 

background, or wish to create a standard Master Page for your school or class, you can save 

whatever you create as a Master Page Template—a subject we already discussed earlier in the 

tutorial. 

 

10.8 INSERTING CLIP ART AND OTHER CONTENT 
Impress has simplified the process of inserting pictures, clip art, tables, Fontwork graphics, sound 

and movie clips, and charts. You learned about this in Lesson 9, but it will be good to review what 

you learned. You’ll also learn in this section how to insert a clickable e-mail address. 

Inserting Clip Art 

Go to View > Slide Sorter and double click on Slide 2 (Introduction) to bring 
up the slide in Normal View 

                                                 
1 LibreOffice maintains a website where you can access, as well as contribute your own, Master Page Templates. 

http://templates.libreoffice.org/template-center?getCategories=Presentation&getCompatibility=any&sort_on=positive_ratings&path=%2FLibreOffice-Templates%2Ftemplate-center&portal_type=PSCProject&SearchableText=
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Next, in the View menu select Slide Layout and, in the Slide Layout menu 
(left of the Impress window), click to select the Title and Two Content layout 

Slide two should now have the bulleted text on the left, with a box on the right for different types 

of content, including text and so forth (Fig. 10.46). 

 

Fig. 10.46 Slide Two: Two Content slide layout 

Click on the lower left Content Selector tool (the Insert Image tool—Fig. 10.46 
above) 

When you click on the Insert Image tool, the Insert Image dialog box will pop up on the screen. 

On your USB drive, navigate to the Work Files for LibreOffice 5 > 
Miscellaneous Files > Practice folder, double-click on the US States image, 
and watch it upload to the slide (Fig. 10.47) 

 

Fig. 10.47 Clip art accessed from the web and inserted onto a slide  

Sometimes you will need to resize your clip art if it appears too small or too large to fit into your 

presentation. This is easy enough to do. 

Content Selector 

tools 

Insert Image 
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If necessary, click once on the clip art to select it, then click on a corner handle 
and drag diagonally left, right, up, or down to enlarge or shrink the image 

When everything looks good on the slide, Save the presentation 

Inserting other pictures or pictures of your own 

A word about Copyright 

The simple rule (law) about Copyright © is this: If you can see it, it’s copyrighted. 

In other words, if you didn’t create it yourself, and you see it out there for the taking, you 

should get permission from the author of the work if you intend to use it, especially if you intend 

to use it for profit. 

Like everything in the law, however, it’s open to interpretation. So, if teachers want to use an 

image they’ve found ‘out there’ to give added meaning or emphasis to something they’re trying to 

help their students learn, they are not obliged to seek permission from the owner of the art because 

there is no question that they are using the image for profit (though the owner would undoubtedly 

be delighted to know their work was being used in this way). 

Once you are comfortable locating and placing clip art into your show, try finding pictures and 

other graphics online. It is simple to insert onto a slide a digital picture that you’ve saved on your 

computer. 

Let’s try this now. If you have a digital picture of your own that you’d like to use for this 

exercise, feel free to do so. If you do not have a picture of your own, you can use a picture of the 

author which is saved in the Work Files for LibreOffice 5. 

Go to View > Slide Sorter and double click on Slide 1 (Title slide) to bring 
up the slide in Normal View 

In the menu of Slide Layouts on the right of the window, click on the Title and 
Two Content slide layout then, in the Content Selector tools, click on the Insert 
Image tool once again 

Now navigate, on your USB drive, to the Work Files for LibreOffice 5 > 
Miscellaneous Files > Practice folder, and double click on Prof Poole 

The picture will quickly appear on the slide, with the handles around it so that you can move it to 

wherever you want on the slide and resize it to fit the space where you want it to go (Fig. 10.48). 

  

Fig. 10.48 The Title Slide with the picture of the author and his credentials inserted onto it 
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Inserting sound  

First, make sure you have your computer Speakers turned on (not muted) so 
that you can hear the sounds you are about to try out 

Inserting a positive feedback slide 

In the U.S. States and Capitals show, we want to give our students a reward for getting each answer 

correct. So, we’re going to insert applause onto every You’re Right! slide. 

Go to View > Slide Sorter and double click on Slide 5 (the first You’re Right! 
slide) to open it in Normal View, then click on the Slide Transition icon on the 
right edge of the Impress window to bring up the Slide Transition pane (Fig. 
10.49) 

 

Fig. 10.49 The Slide Transition pane 

In the Slide Transition dialog, select the Uncover Transition Variant (Top to 
Bottom), set the Duration: at 3.00 seconds, and in the Sound: menu select 
Applause 

Now scroll to Slides 8 and 11 and repeat the above steps (inserting the 
Applause sound with the same Duration and Transition Variant) 

You should now have applause on each of your positive feedback slides. 

Save the presentation with your new positive feedback sound effects 

A caveat (warning) about sound. Like any bell or whistle, it’s easy to get carried away with sounds. 

Stay focused on the purpose of your show and your audience’s needs. A kindergarten class will 

welcomes lots of sounds, and the whackier the sound the better.  For a presentation to the Board 

of Education, however, a more professional approach may be required! 

Inserting a negative feedback sound 

Now you need to insert a sound on each of the Sorry. Try again. slides (Slides 6, 9, and 12). To 

vary things a bit, we’ll use an image to go with each sound. 
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The images have been saved for you and you’ll find them on your USB drive in the Work Files for 

LibreOffice 5. 

Go to View > Slide Sorter and double click on Slide 6 (the first Sorry. Try 
again. slide) to open the slide in Normal View, then click on Insert menu > 
Image 

In the Insert Image dialog box, navigate to your USB drive > Work Files for 
LibreOffice 5 > Miscellaneous Files > Practice folder and double click on 
the file called Falling Downstairs to Insert it onto Slide 6 

Grab any of the handles around the image and size it as large as you want 
without covering other data on the slide, then slide the image anywhere off 
to the left of the Slide Control (Fig. 10.50) 

 

Fig. 10.50 Sized image on left of Slide Control button 

Now for the animation and sound to go with the picture. 

Click on the Falling Downstairs image and, in the Sidebar Settings on the 
right edge of the window, again click on the Slide Transition icon (Fig. 10.51) 

 

Fig. 10.51 Slide Transition tools in the Sidebar Settings 
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For the Transition: select Shape; for the Effect: select Plus, for the Duration: 
select 3.00 seconds, and for the Sound: select falling (Fig. 10.51 above) 

Do the same thing for Slide 9 and Slide 12 except for Slide 9 use the image 
called Bomb; and for Slide 12 use the image called Explosion (you’ll find the 
images in the Miscellaneous Files > Practice folder), and select your own 
choice of Transition, Effect, Duration and Sound 

Save your work again when you’ve completed this exercise 

Inserting Videos or Animations 

Inserting movies (or video) is just as easy as inserting clip art or sounds. Whether it’s an animated 

clip or a short video clip, the steps are the same. 

Open Slide 13 (Great Job, Class!) in Normal View 

You could go to the web to search for video and clip art examples to use on the slide, but for 

convenience sake you will find the animated image you need in the Work Files for LibreOffice 5. 

In the Insert menu > Image… dialog box navigate to your USB drive > Work 
Files for LibreOffice 5 > Miscellaneous Files > Practice folder and double 
click on the file called Excited Man to Insert it onto Slide 13  

Feel free to grab the image and move it to wherever on the slide looks good 
to you—and grab the handles to resize the image (the larger the better as 
long as it fits on the slide without covering any other data) 

When you are done, your slide will look something like that illustrated in Fig. 10.52. 

    

Fig. 10.52 Final look of the Conclusion Slide 

How about some sound with that? 

For the Duration: select 3.0 seconds, select romans for the Sound, click to 
put a check mark/tick next to Loop until next sound and for the Advance 
timing click in the Radio button next to Automaticlly after: and set the time 
to 10.0 seconds 

Save the presentation before moving on to the last task 

You should test the work you’ve done to this point to make sure it works the way you want it to. 
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Go to Slide Show menu > Start from first Slide and answer each question 
incorrectly first, then watch as the Text Object hyperlink takes you to the 
Wrong Answer feedback slide 

Test all the Text Object answers to make sure the hyperlinks you put on them 
work appropriately; also test to make sure that when you click anywhere on 
the slide, other than on the Slide Control, the show doesn’t go anywhere 

Check everything carefully—do the sounds work? and the animations? and so 
forth? Be careful and self-critical—you want to do the best job you can 

Give yourself a round of applause if everything worked correctly. If, on the other hand, a hyperlink 

or Slide Control doesn’t work, don’t panic. You can remove a Slide Control by simply right 

clicking on it and selecting Cut from the context menu. Then follow the steps above again 

carefully, and you should be able to straighten things out. 

Keep in mind, as always, that moderation with content such as clip art, sounds, and movies is 

key. Your topic (the Function), not the style (the Form) of your show, must always be the main 

focus. 

 

10.9 SOME FINAL THOUGHTS ABOUT PRESENTATIONS 

Think you're ready to make some engaging and relevant interactive Impress shows? Before you 

jump in, consider the following suggestions. 

It's inevitable: Impress is so easy to use and fun to play with that every beginning user from ages 

6 to 96 wants to use all the tricks and tools available. Yet, always remember the golden rule: 

Substance before Style. Garbage, no matter how colorfully arrayed and beautifully orchestrated, 

is still garbage.  

Keep your focus on the content, then use only those tools that are appropriate for your audience 

and task. Got a group of sleepy students that don't seem thrilled about photosynthesis? Sure, throw 

in lots of sound and moving text. But for test-taking and concept review, make the presentation 

simple, clean, and succinct. 

Next, remember the three secrets to creating an Impress presentation: plan, plan, and plan? 

This is even more vital in the interactive show, when one bookmark linking the wrong answer (My 

teacher is NOT a mammal.) could have unexpected consequences. Some of us learn better when 

we can visualize our task, so you may want to sketch out your ideas on paper or on a Writer 

document until you feel comfortable with this new testing method. 

Lastly, just because you've created your presentation doesn't mean you've finished. After 

planning a presentation and creating the show, you need to spend time practicing using it. Take 

the test yourself. Dummy-proof your show as much as your grade-level dictates (more Slide 

Control on the introductory slides for example for younger children). The beauty of all digital 

content such as an Impress presentation is that it is easy to fix problems you may find, easy to 

update, easy to improve, easy to maintain. So take the trouble to fine-tune your work when you 

see that it needs further work. 

 

LOOKING BACK 
You've viewed and created your own interactive Impress presentation. You've mastered hyperlinks 

and Slide Control as a way to break free of the traditional linear nature of Impress shows. You've 
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changed the design and inserted content into your presentation. Finally, you've learned some tips 

on how to keep the focus on what the students need to learn, not on how pretty the presentation is. 

Creating an interactive Impress presentation can be time-consuming and, for that reason, 

should be used only occasionally. But, learning how to create such shows is not difficult, and 

numbers of teachers are now using this strategy not just to make reviewing material more fun, but 

also as a student activity. 

Students in grades 5 and up at least can be taught how to create interactive Impress 

presentations in a fairly short amount of time. One Language Arts teacher in middle school has her 

students create interactive novels using this strategy. The middle school students write stories that 

have several options for plot, then have younger students read and play around with the stories. 

For example, a dragon may have three caves he can go inside. Click on one cave, and the dragon 

meets up with a knight with sword in hand. Click on another cave, and the dragon meets his long 

lost mother. 

Because hyperlinks do not have to be linked to text but can be linked to clip art or pictures, 

interactive Impress shows can be used with grades preK-2 with ease. The title of a slide might be 

"What color is the ball?" An image of a red ball is on the slide, along with four squares, each 

containing a different color. If the student clicks on the red square, the square's hyperlink takes her 

to a slide with the word Red on it and the red square. Depending on the students' computer skills, 

teachers can project such a show for the whole class to walk through together, put the show on one 

computer in the classroom, or place the show on lab computers for whole class instruction. 

As you consider how to apply interactive shows in your classroom, make sure you take into 

account when and how each student will access the show, and weigh time considerations against 

learning benefit. These shows can be a great motivator during the winter doldrums or following a 

particularly intense unit. Use them occasionally and perhaps have your students create some. You'll 

be surprised at how much fun they have and how much learning takes place. 

 

LOOKING FORWARD 
ESSENTIAL LibreOffice has introduced you to many of the fundamental features of the Impress 

integrated software package. But there are many more advanced features for you to learn. Your 

challenge now is to capitalize on your hard work in two ways. 

1. Use the Office programs as much as possible in order to consolidate your skills and sharpen 

them to the point where they become second nature. 

2. Extend your knowledge by studying the software beyond what you know. Step out on the 

path that leads to your becoming a power user of productivity software such as this. Get 

hold of the LibreOffice reference manual. Discover what else the software can do to 

improve the quality of your work and make you more productive. Knowledge is power. 

You will be surprised to discover what else LibreOffice in particular, and the computer in 

general, can do for you. 

 

SKILL CONSOLIDATION 
1. Prepare an interactive presentation that introduces yourself to your class at the start of a new 

school year. Have five silly questions about your education, hobbies, family, etc. Students will 

enjoy learning about you and will have a great introduction into your class. Use any graphics 
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and sounds you like. Be sure to have a Title Slide, an Intro Slide, and an Acknowledgements 

Slide. 

2. Prepare an interactive presentation that reviews a basic concept that must be memorized in your 

class (times tables, grammar rules, Spanish vocabulary, periodic table). Have five questions 

related to the topic. Depending on your class, have the presentation on a classroom computer, 

E-mail it to your students to study with from home, or run it in the computer lab. Use any 

graphics and sounds you like. Be sure to have a Title Slide, an Intro Slide, and an 

Acknowledgements Slide. 

3. Modify the steps in this chapter and teach your students how to make an interactive Impress 

presentation. Have them create a quiz on a hobby or sport of their choosing. This not only 

teaches them advanced computer skills, but it helps them synthesize and organize information. 

The hyperlink and Slide Control steps require clear organization skills and logical thinking, 

great practice for real classroom learning. Use any graphics and sounds you like. Be sure to 

have a Title Slide, an Intro Slide, and an Acknowledgements Slide. 

4. Prepare a presentation that works like an Internet scavenger hunt. Choose your own topic (say, 

Dinosaurs). Come up with five questions related to the topic. On each of the five Question 

slides, make each question a hyperlink to a Web site with the answer on it. Then have four 

possible answers to each question, only one of which is correct. Follow the steps in this chapter 

to make the presentation interactive. For each question you will need two hidden slides with the 

answer, one Correct and the other Incorrect. After the Title Slide, you will have an Introductory 

Slide which explains to the student how to proceed with the exercise. Thus, your Impress will 

have 18 slides in all—a Title Slide, an Introductory Slide, 15 Question and Answer slides, and 

an Acknowledgements Slide. Students will have to search the linked sites for the information, 

requiring more sophisticated thinking skills than simply memorizing facts. As in the lesson (US 

States and Capitals), when the student clicks on an answer, the slide sends them to a hidden 

slide which indicates whether the answer is right or wrong. If the answer is wrong, a button on 

that slide sends the student back to the question slide. If the answer is correct, a button sends 

the student to the next Question slide in the presentation. Use any graphics and sounds you like.  


