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9 
IMPRESS PRESENTATIONS 
Creating slide shows and related teaching 
materials 

 

LEARNING OUTCOMES 
This lesson introduces you to those features of LibreOffice Impress that are particularly valuable 

in the teaching and learning environment. You will learn how to use Impress to capture your ideas 

in outline form and convert those ideas into multimedia presentations. You will also learn how to 

use the application to create your own presentations both from scratch and with the help of one of 

the Impress Wizards. 

Most people think of a slide show as a way of presenting a series of still images or photographs 

using a slide projector. If you think about it, however, a slide does not have to be a still image; 

using Impress it can also be an audio or video clip. For that matter, a slide does not have to be even 

a picture; it can also be text, an outline of ideas, whatever you want. 

Impress provides an easy-to-use multimedia presentation production system, which you will 

no doubt enjoy learning and which you and your students will find useful for individual or group 

projects of all kinds. 

In the various courses that you take as an Education major you learn how to design curricula, 

with lesson plans and unit plans. You also learn methodologies for effective teaching. The better 

the teacher you are, the more Impress will empower you in your work. 

Here, then, are the topics that will be covered in this lesson: 

• introductory thoughts about presentations; 

• Impress at work; 

• building the presentation; 

• adding bells and whistles to the presentation; 

• printing presentation handouts. 

 

A caveat before you begin: 

In the earlier tutorials for LibreOffice, the steps to accomplish the tasks assigned have been rather 

detailed. This time, however, the directions will be less specific, especially in the latter half of the 

lesson, because Impress is a program you can figure out by playing with it. You’ll find that you’ll 

soon become confident about how to design and develop high quality multimedia slide 

presentations. So relax, and have fun! 
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9.1 INTRODUCTORY THOUGHTS ABOUT PRESENTATIONS 
Making a successful—well-designed, content-rich, pedagogically-sound—Impress presentation 

requires forethought and advance preparation. It’s rather like what good cooks or chefs do before 

starting to cook a delicious dish of food. They read the recipe, make sure they have all the 

ingredients they need, gather all the ingredients together—the raw food such as vegetables and 

eggs and milk and wine and spices and other flavoring—what they call the mise en place. They 

make sure they have all the tools they need to do the job. 

Good cooks don’t start cooking till they’re good and ready. 

In the same way, you have to get your thoughts together, know what you’re going to talk about, 

and have your audio-visual material gathered together in one place (mise en place) so that when 

you come to create the presentation, it’s a snap. 

A good presentation, like a term paper, is usually based on an outline, such as is illustrated in 

Fig. 9.1. 

  

Fig. 9.1 Outline for the Tudor Monarchs presentation 

You see on the left an outline of the text for each slide in the Tudor Monarchs presentation. Think 

of the titles and text for each slide as an outline you would have made for a high school or college 

paper. Similar, right? This is why the outlining tool is built into Impress—to help you plan. 

Remember the golden rules of successful design: Rule 1—Plan; Rule 2—Plan; Rule 3—Plan! 

These golden rules apply whether you are designing a term paper, an audio-visual aid, a class 

outing, or a class syllabus and schedule. 

You might begin with a brainstorming session to help you get an outline. During 

brainstorming, members of the group would come up with as many ideas as possible related to the 

topic of the project. Nobody's ideas are rejected in the early stages so as to encourage a fertile flow 

of useful suggestions. 

The result of the brainstorming session might be a somewhat disorganized list of ideas. This 

list might have been entered directly into the computer during the brainstorming session, or it 

might have been collected on a blackboard or flip chart. Before changing the list into outline form 

you would re-organize it so that the ideas flowed naturally and logically from one to the other. 

Along the way you might toss out some of the ideas for one reason or another. Eventually 

you'll have a working list which would end up as an outline, perhaps in a word processor document. 

Each of these icons 

represents a slide in the 

Impress presentation 

This shaded 

slide is a 

Hidden Slide 
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9.2 IMPRESS AT WORK 
Let’s see these ideas and others at work by looking at an example of an Impress presentation. 

Turn on your computer, open Libreoffice then click on Open File and, in the 
Open dialog box, navigate to your disk drive > Work Files for LibreOffice > 
Impress Files folder and double click to open the Tudor Monarchs 
presentation 

Fig. 9.2 shows the Tudor Monarchs presentation in Normal View as it probably appears on your 

screen right after you open the document. 

 

Fig. 9.2 The Tudor Monarchs presentation 

If you do not have Normal View showing on your screen, this is simple enough to fix. 

In the View menu select Normal 

Different ways to view the slides in your presentation 

Normal view 

This is the view you see illustrated in Fig. 9.2 above. It is the one you'll use most of the time while 

you're actually putting information on each slide. In this view, there is the left hand frame where 

you see thumbnails of all your slides in a scroll box. In the center of the window you have the slide 

you are actually working on—the active slide. Then, over in the right hand frame you have the 

Properties Pane (not shown in Fig. 9.2 above), where you'll find more tools to help you to develop 

your presentation. 

Outline View 

The Outline View (Fig. 9.3 next page) lets you see just the text on each slide. You can use the 

Outline View to map out/plan the content of your show before you add graphics and colors and 
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backgrounds and so forth. Fig. 9.3 shows the Outline View for the Tudor Monarchs presentation. 

Compare it with the Normal View shown in Fig. 9.2 above. 

 

Fig. 9.3 Outline View of the Tudor Monarchs presentation 

Notes View 

The Notes View is especially useful if you want to amplify the content of each slide, either for 

your own use as the presenter, or for your students or for whoever is in your audience who would 

like more information than is on each actual slide. In the Notes View you are presented with a 

smaller version of each slide, one by one, with ample space to add extra textual notes pertaining 

to the content of each slide, as illustrated in Fig. 9.4. 

 

Fig. 9.4 The Impress Notes View showing the supplementary notes for Slide One 
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Handout Master View 

Anyone who gives a presentation is, in a way, a teacher. The people listening to him or her are, in 

a way, students hoping to learn something they didn't know before. One of the problems with being 

a student is that it can be difficult to recall what the teacher is trying to get across. Good 

teachers/presenters give their audience the opportunity to take away at least a summary of what 

they have had to say. Hence handouts; and LibreOffice makes printed (hardcopy) handouts a snap. 

Fig. 9.5 illustrates the Impress Printed Handout options. 

 

Fig. 9.5 The Impress Print (Handouts) dialog box 

Handouts are one way to serve the purpose of providing a textual summary to go along with what 

should be attractive, eye-catching, thought-provoking slides. The Impress Handout View makes it 

easy to format and print (or e-share through email, Facebook, and myriad other online social 

media) the Impress presentation that you have so carefully designed and produced. A useful final 

slide in an Impress presentation will provide a web link to the set of handouts that go along with a 

presentation. Your audience or students will be very grateful for that. 

The best presentations, however, are NOT slide intensive!  In other words, if you are teaching 

for 40 to 50 minutes, you shouldn’t need more than half a dozen slides. The worst thing a teacher 

can do is fill slides with text and then just read from the slides. That’s called “Death by Impress.” 
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Slide Sorter view 

This is the view you see illustrated in Fig. 9.6 and it is the one you'll find most useful when you 

want to get an overview of your show while you’re working on it, since you'll be able to see most, 

if not all, of your slides laid out for you on one screen or page. 

You also can easily move your slides around by using the mouse to slide them into place, changing 

the order to suit your purposes. This is why it's called the Slide Sorter view. 

Let's further check out the Slide Sorter view now. 

In the View menu select Slide Sorter view (Fig. 9.6) 

 

Fig. 9.6 The Slide Sorter View of the Presentation 

Take a look at the Slide Sorter View window that is presented to you (much the same as Fig. 9.6 

above, though your screen may be a different width, so the slides may be arranged differently 

across the page). The presentation demonstrates some of the basic features of Impress. By the end 

of this lesson you will be able to build your own presentations along the same lines. 

Features to look out for in the demonstration presentation 

It’s time you checked out the Impress presentation about the Tudor Kings and Queens of England. 

In the View menu select Normal View, then in the Slide Show menu select 
Start from first slide 

While you click your way through the Tudor Monarchs presentation, look out for the following 

Impress features that have been used in the creation of the Tudor Monarchs slide show. 

Transition effects and animations 

The transition effects from one slide to another and the text animations (which determine how the 

text will arrive on each slide) have been set at random for the demonstration. This is to give you 

some idea of the variety of transitions and animations you can use in Impress. But this is not 

necessarily a good thing to do. Normally you would not want to use many, if any, different 

transitions and animations since it might distract from the impact you are trying to make. A good 

designer homes in on a style that he or she likes best for a particular theme and tends to stay with 

it for all the slides in the show. 
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Inserting clip art 

LibreOffice offers a database of clip art images and sounds/audio on a wide range of topics. This 

is available to all the software in the LibreOffice suite. 

In the View menu select Gallery, then check out all the Themes by clicking on 
the list on the right side of the Impress window 

Fig. 9.7 illustrates the Gallery from which you can select clip art to insert onto your slides. 

 

Fig. 9.7 Ribbon for inserting images, illustrations, and other media 

You can download clip art, photographs, sound files, video clips and other media from a file you 

have saved on disk, or from collections available free of charge on the Web. Or you can bring onto 

a slide all kinds of charts and tables from other LibreOffice programs such as Writer or Calc.  

You can also scan pictures directly onto a slide. So, if you have a scanner connected to your 

computer, you’re in business. 

Close the 

Gallery by 

clicking on 

this button 

here 
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If you’re looking for multimedia material to accompany your slides, the Web is the place to go. 

Companies, universities, schools, and individuals, especially teachers, are creating and making 

available excellent multimedia materials. These materials are available, mostly free of charge, 

from websites such as flickr.com, youtube.com, and so forth. 

After you’ve checked out the Gallery, click on the button to the center left of 
the Gallery to close it 

Impress makes it easy to incorporate such material into presentations, with or without 

accompanying text. Remember though: YOU MUST ALWAYS GIVE CREDIT FOR 

ANYTHING YOU ACCESS ONLINE. 

Buttons, Slide Controls and Hidden Slides  

Notice the use of buttons to allow the user to control movement through the slides, thus making 

slideshows both interactive and non-linear—in other words, the user has control over the 

sequencing of the slides. 

For example, in the Tudor Monarchs slide show there is a Hidden Slide (slide #5) which is 

only able to be seen if, on slide #4, you click on the orange button to see the answer to the question 

posed there. Let’s check this out. 

If you are actually viewing the slide show, hit the Esc(ape) key on the keyboard 
to exit the slide show then, in the Slides menu on the left of the Impress 
window, click on Slide 4 to make it the active slide 

In the Slide Show menu click on Start from current Slide 

Slide 4 is showing on your full screen as an active slide in the show. 

Now, read the text on the slide, but DON’T click on the orange button towards 
the bottom of the slide; instead click on the yellow button at the top of the slide 
to proceed to the next slide 

Notice that the presentation skips straight to Slide 6. Fortunately, there’s a button on slide 6 which 

takes you back to Slide 5 if you don’t already know the answer to the question.  

So, you can create interesting interactive learning materials using Impress. Lesson 10 will help 

you learn more about interactive presentations such as this. Your students, too, will have a lot of 

fun using Impress to develop projects of all kinds for every subject under the sun. 

Let’s continue checking out a couple of other Impress features. 

Timing and other considerations 

Fig. 9.6 on page 306 shows the Slide Sorter View of the presentation. Fig. 9.8 on the next page 

also highlights the range of transitions you can choose, how fast you want the transition to occur, 

whether you want a sound to accompany the transition from slide to slide, and so forth. 

Notice, in the Slide Transition pane on the right-hand side of the Slide Sorter window, that the 

transition (Random Bars Transition) is set to Fast, with an accompanying sound called Apert. 

Each slide will advance automatically after 15 seconds, unless the user clicks the mouse on the 

“Click to proceed” button on each slide, in which case the slide will advance right away. 

Under normal circumstances, 15 seconds should be more than enough time for anyone to read and 

absorb the data on slides such as those in the Tudor Monarchs presentation. So, you might think 

15 seconds is too long to hold the user’s attention. Won’t they get antsy waiting for the next slide? 
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Fig. 9.8 The Slide Sorter View showing the Slide Transition settings 

Well, as you noticed when you reviewed the slide show, there is a button which the user can click 

on to control when to proceed to the next slide. The speed at which our minds absorb data varies 

enormously from person to person. Thus, by allowing a generous amount of time, along with user 

control, you're allowing each individual user the freedom to proceed at his or her own pace.  

You always should design teaching materials and lessons in such a way as to address individual 

student needs. The timing features of Impress allow for this. 

Acknowledgements: Always give credit where credit is due 

The last slides in any presentation, just as the last item in a term paper or the credits that run at the 

end of a movie, should usually be your list of sources cited or used—your Acknowledgements and 

Credits slides (Fig. 9.9). 

 

Fig. 9.9 The Acknowledgements and Credits slides 

So… If you haven't already done so, in the Slide Show menu select Start 
from first slide 

Click your way through the presentation now (click on the Buttons on each 
slide to proceed to the next slide) 

The slides have been timed to allow the user (right now, that’s you) to easily view and read what 

is on each slide without feeling rushed. If you want the slides to proceed at a faster pace, simply 

click on the Click to proceed button on each slide. 
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When you have finished reviewing the Tudor Monarchs slide show, exit the 
show by hitting the Esc(ape) button in the top left corner of the keyboard 

So much for an overview of Impress. No doubt you are anxious to start creating your own 

presentation. The next section will help you do just that. 

Close the Tudor Monarchs presentation when you are ready to continue 

 

9.3 BUILDING A NEW PRESENTATION 
Preparation of the outline 

You are going to prepare a simple outline, which will give you the experience to prepare your own 

outlines when you develop your own Impress presentations. 

It's tempting to just barrel along into a new document or database, whether in Writer, Impress, 

or Base, like someone tempting fate at Niagara Falls! But you should resist doing so at all costs 

because you'll save yourself no end of time in the long run if you carefully plan what you want to 

do. You really have to think ahead if you want to get where you want to go. Otherwise, there's no 

telling where you'll end up! 

So whenever you’re preparing a new Impress presentation, take your time. Think about it; 

gather your data; brainstorm, with yourself at least and with friends if necessary. Don’t just blunder 

along, OK? So let’s begin. 

In the top level menu of LibreOffice applications, select Impress Presentation 
to open a new Impress presentation 

You’re presented with a dialog box which prompts you to Select a Template, 
but you don’t want to do that yet, so click on the Cancel button 

Immediately, go to File > Save As, navigate (Browse) on your computer to 
your disk drive > Work Files for LibreOffice > Data Files folder and Create 
a new folder called Impress Documents 

Open the Impress Documents folder, name the new presentation 
Screenbeans, and click on Save 

When you first open a new, blank presentation in Impress, the program presents you with the 

Normal View (Fig. 9.10). 

 

Fig. 9.10 New Presentation window in Normal View 
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The first slide, by default, is in the Title Slide layout. This is because you would normally want to 

start out a presentation with a slide that displays the title of your show, along with sub titles such 

as your name and so forth. You don't have to use this slide layout, of course. 

Impress provides a set of slide layout templates from which you can choose when you are 

working on a slide, including one layout which is blank. The Blank Slide template allows you to 

create slides from scratch, entirely of your own design. 

In the View menu select Slide Layout 

Impress now opens up the Slide Layout Properties pane on the right side of the window (Fig. 9.11). 

 

Fig. 9.11 The Slide Layout Properties pane 

Let’s take a look at these different Slide Layouts (Fig. 9.12). 

 

Fig. 9.12 Slide Layouts (annotated) 

Blank Slide 

Title Only 

Title and 2 

Content 

Title, Content 

& 2 Content 

Title, 2 Content 

over Content 

Title, Content 

Over Content 

Title Slide 

Title, Content 

Centered 

Text 

Title, 2 Content 

& Content 

Title, 4 Content 

Title, 6 Content 

Click on this 

button to close 

the Properties 

pane 
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Click on each of the Slide Layouts to check them out in Normal View 

After you’ve checked out the various slide layouts, click on the Title Slide layout 
to select it as the first slide in your presentation, then click on the button 
immediately to the left of the slide layouts (see Fig. 9.12 above) to close the 
Layout Properties pane 

The Title slide is presented in the Normal View (Fig. 9.13). 

 

Fig. 9.13 The Normal View of the Title slide 

Typing the outline entries 

The Normal View is fine after you have planned and built your presentation and you want to check 

out and edit individual slides that you have already created. But when you are at the planning 

stages and you want to create an outline of the text you want to include on each slide, it is 

sometimes best to use the Outline View. Impress provides a lot of help such as this while you're 

developing your presentation. 

Let’s switch to the Outline View now. 

In the View menu click on Outline to switch to Outline View (Fig. 9.13) 

  

Fig. 9.13 The Outline View of the screen at the start of a new blank presentation 

Here is where you will 

type the text for the 

first slide 
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As you type the text for each slide in the Outline View, the text will be associated with the final 

version of each Impress slide with no extra effort on your part. You’ll see how this works when 

you switch back to Normal View after you have typed in the outline that you see illustrated in Fig. 

9.14 below. 

Don’t start typing text just yet, though. Refer to the outline as you work your way through the 

directions that follow Fig. 9.14. 

  

Fig. 9.14 The outline for the Screenbeans presentation 

Next to the icon for the first slide, type the title No Problems, Only Solutions 
(see Fig. 9.14 above), then hit Enter on the keyboard 

Impress now presents a new icon for a second new slide because it assumes that you have finished 

adding text to the first slide. But you haven’t finished with the first slide yet since you need to add 

the author’s name as a sub-title on the Title slide. To do this, you need to Demote the next set of 

Icon for 

the first 

slide 
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text (By [author’s name]) so that it stays on the same (Title) slide (which means you must decrease 

its level on the slide). You’ll see how to do this as you follow along with these directions. 

Switching levels  

Impress does have a Text formatting toolbar which has tools for promoting and demoting levels 

of text in an outline (Fig. 9.15). 

 

Fig. 9.15 Tools for Demoting and Promoting levels on an Impress slide 

The easiest way to demote and promote slide levels, however, is to use Quick Keyboard 

Commands1. The Tab key, for example, demotes (moves down a level on the same slide), and 

Shift-Tab promotes (moves text up a level on the same slide, or moves up to a whole new slide). 

As you use these quick keyboard commands, you’ll soon get the hang of it. 

Demoting to a lower List Level 

Hit the Tab key to demote to a lower outline level now, then type By [your 
name]—type your own name, of course—not “your name” or “Bernie Poole!”—
and hit the Enter key 

Fig. 9.16 shows how your outline entry for the first slide will look at this stage. 

  

Fig. 9.16 The outline entry for the first slide 

That’s all you need by way of text on the first slide. Now you need to set up for a new slide. To do 

that in the outline, you hit Shift-Tab, which takes the level back to the top level of a New Slide. 

                                                 
1 The author has prepared a “crib sheet” of LibreOffice Quick Keyboard Commands which is available on the web 

at http://www.pitt.edu/~poole/libreoffice6Tutorials/libreofficeBackcover.pdf. 

Notice the cursor, expecting you to type more 

text on the first slide. But you need to promote 

to a new slide by hitting Shift-Tab. 

Demote 

tool 

Promote 

tool 

http://www.pitt.edu/~poole/libreoffice6Tutorials/libreofficeBackcover.pdf
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Promoting to a higher List Level 

Hit the Shift-Tab keys together to move up (promote) to a higher (top) level in 
the Outline 

Notice that you now have a top level icon for a new slide, and the cursor is waiting for you to type 

in the text for this second slide (Fig. 9.16) 

 

Fig. 9.16 Icon for the second slide 

Now you are ready to type in the entries for the second and remaining slides. As you know, the 

content for all the slides is illustrated in Fig. 9.14 on page 313. Let’s continue with Slide 2. 

Type Confusion for the title of Slide 2, and hit Enter, then hit Tab to demote 
to a lower List Level 

Look at your outline now and notice that the next entry you type will be indented and bulleted. 

Type the lower level text for the second slide (A problem often presents 
itself…, etc.) from Fig. 9.14 on page 313, then hit Enter 

That is all you need by way of text for the second slide. As you can see, you must now Promote to 

a higher level for the new slide 3. 

Hit Shift-Tab 

This starts a new slide (Slide 3). You should be starting to get the hang of this. 

Go ahead and complete the rest of the outline illustrated in Fig. 9.14 on page 
313, demoting (Tab) and promoting (Shift-Tab) the text levels as you go 

After you have typed the Title and text entries for all 9 of the slides, navigate 
to your disk drive > Work Files for LibreOffice > Data Files > Impress 
Documents folder and Save the Screenbeans Impress slide show 

Now go to View menu > Slide Sorter to switch to Slide Sorter view (Fig. 9.17) 

 

Fig. 9.17 Slide Sorter View 

Slide 2 
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Changing the layout of Slides 2-9 

You may notice that Impress automatically selects Title, Content layout for all the slides after the 

Title slide. But the new layout we need for slides 2 thru 9 is Title and 2 Content. Let’s fix this first. 

In the Slide Sorter view, click on the thumbnail for Slide 2 (Fig. 9.17 above), 
then hold down the Shift key and keep it down while you click on Slide 9 

Slides 2 thru 9 should all now be highlighted (Fig. 9.18 below). 

Now, with Slides 2 thru 9 selected, go to View > Slide Layout to bring up the 
Properties pane with its slide controls and menu of Layouts (Fig. 9.18) 

 

Fig. 9.18 Slide Sorter View showing the Properties pane 

In the set of Layouts templates in the Properties frame on the right of the 
Slide Sorter window, locate and click on the Layout for a Title and 2 Content 
slide (Fig. 9.18 above) 

Now click on the X at the top right of the Slide Sorter window to close the 
Properties pane and check out the slides with the new Title and 2 Content 
layout (Fig. 9.19) 

 

Fig. 9.19 Slides 2-9 with Title and 2 Content layout 

Click on the X to 

close the Properties 

pane 
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You can now see a thumbnail of each of slides 2-9 with, on the left hand side, the text you typed 

in and, on the right, an empty space for further slide content, which can be more text (or a table 

from a Base database, or images, or a chart imported from a Calc spreadsheet, or even a movie). 

Time to Save your work (Ctrl+s) 

Notice how easy it is, using the Slide Sorter view, to check out how your work is progressing. 

Still in the Slide Sorter view, click once on Slide 2 to make it the selected slide 
and click on the View menu > Normal to switch to the Normal View of the 
slides (Fig. 9.20), then Save the Screenbeans presentation once more 

 

Fig. 9.20 Normal View for Slide 2 showing the Content Placeholder and the 5 Content options  

In Normal View you see the slide as it will show in a presentation. All you have to do now is add 

an image in the Content Placeholder. In Lesson 10 you’ll have the opportunity to practice adding 

a table from a Base database, a chart from a Calc spreadsheet, and a movie, too. 

Adding pictures to the slides 

For Slides #2 through #9 you are going to insert a Screenbean2 graphic in the Content Placeholder. 

The set of pictures that you are going to use for this presentation are from Microsoft 

Corporation's clip art gallery. They may not be available on your computer since you may not be 

working online. So, for the sake of this exercise, a folder containing the eight Screenbean clip art 

drawings has been prepared for you (listed in Fig. 9.21 on the next page). You’ll find the folder on 

your disk drive, inside the Work Files for LibreOffice folder. 

On the right hand side of slide #2, click on the Insert Image tool—the lower 
left of the four Insert object icons (Fig. 9.20 above) to bring up the Insert Image 

                                                 
2 Screenbeans are cartoon characters created by Microsoft, Inc. 

Content 

Placeholder 

Insert Table 

Insert Image 

Insert Chart

Insert Movie 

Insert Text 
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dialog box, then navigate to your Work Files for LibreOffice > Impress Files 
> Screenbeans folder (Fig. 9.21) 

 

Fig. 9.21 The Insert Image dialog box listing the 8 Screenbean image files 

In the Screenbeans folder there are the 8 pictures you need for the next 8 slides in the presentation. 

Fig. 9.22 lists the pictures in the order in which you should use them in the slides. 

  

Fig. 9.22 The sequence you will use for the Screenbean pictures in the presentation 

In the Screenbeans folder, double click on the Confused file (“Confused” 
with an “f”, not “Contused” with a “t”!) 
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Impress inserts the Screenbean figurine on Slide 2 inside the right side placeholder, with handles 

around it so that you can re-size it, if necessary, to fit the space provided for it on the slide.  

Check to make sure the art is correctly positioned on the right side of the 
slide (it should look something like Fig. 9.23), then click anywhere off the 
image in order to set it in place (though you can click back on it anytime to later 
change the image’s size and position) 

 

Fig. 9.23 Slide 2 with the image in place 

Repeat this exercise for the next seven slides, working from the Slides Panel 
clicking on Slide 3 first the on each slide in turn to bring up the Normal View 
for that slide, then clicking on the Insert Image icon and loading the 
Screenbean images one by one in the order they are listed in Fig. 9.21 on the 
previous page 

When you are done with slide #9, Save your work to this point (Ctrl+s), then 
click on the View menu > Slide Sorter 

In the Slide Sorter view, your Impress presentation should now look like Fig. 9.24. 

 

Fig. 9.24 Screenbeans slide show after inserting all the Screenbeans images 
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9.4 ADDING BELLS AND WHISTLES TO THE PRESENTATION 
Resizing the Screenbeans on each of the slides 

The Screenbean images on each of the slides are smaller than they need to be. If necessary you 

could also crop an image to select out just the part of the image you want to use. To do this you 

would right click on the image and, in the context menu that pops up, select the Crop option. You 

don’t need to do that here, but you could if you wanted to. 

In the Slide Sorter View, double click on Slide 2 to open it in Normal View 

Click on the Screenbean image to bring up the small blue handles around it 
(Fig. 9.25 below); then grab any one of the CORNER handles to stretch the 
image so that it is as large as possible in the space on the right side of the 
slide; just be careful not to distort the image or to overflow the borders of 
the slide, or to drag the top of the image much higher than the top line of 
sub-text as illustrated in Fig. 9.25 

  

Fig. 9.25 Stretch the Screenbean using the corner handles 

Now do the same with the Screenbean images on the other 7 slides—to end 
up with something like Fig. 9.26—then Save your work once more 

 

Fig. 9.26 Screenbeans presentation after resizing the images 
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Adding Transitions, Speed and Sound effects, and Timings 

The following task would best be done—and easiest to do—while you are in the Slide Sorter View. 

If not, go to View > Slide Sorter, but assuming you are still in the Slide Sorter 
view, go to View > Slide Layout to Open the Properties pane (Fig. 9.27) 

The full set of slides plus the Properties pane should now be showing on your screen (Fig. 9.27). 

 

Fig. 9.27 Impress Slide Sorter window after showing the Properties pane 

For this exercise, you are going to add the same Timing, Sound effect, and Slide Transition to all 

the slides, though you could, if you wanted, use different timings, sound effects, and transitions 

for each individual slide. You’ll practice doing this in Lesson 10. 

Adding Slide Transitions 

In the Edit menu, click on Select All (Ctrl+a) to select all the slides, then click 
on the Slide Transition button (Fig. 9.28) 

 

Fig. 9.28 The Slide Transition button 

If it helps, you 

can use the 

mouse to drag 

this divider left 

or right to resize 

the Properties 

pane 

Click on this radio button to 

set automatic timing after a 

certain number of seconds 

Be sure there’s a 

check/tick in this box 

Click here after you’ve made all your 

other selections for the Slide Transitions 
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This Slide Transition button brings up, on the right side of the Impress window, the Slide 

Transition pane (Fig. 9.28 previous screen). 

To get a Live Preview of any of the transitions, make sure the box next to 
Automatic preview at the bottom of the Slide Transition pane is 
checked/ticked (see Fig. 9.28 above) 

Click on any slide, then click on a Transition in the menu and watch the effect 
of the slide transition on the selected slide 

Try several of them to get a feel for how they work, then select the one you 
most like 

Adding Speed and Sound effects 

Fig. 9.28 above illustrates the Modify Transition options. A Transition can be timed to happen at 

any one of three speeds (Durations): Fast (1 sec), Medium (2 sec), or Slow (3 sec). We’ll go with 

Medium speed (2 sec), but feel free to choose whichever speed appeals to you. 

We’re also going to use the Apert sound effect, but again feel free to choose any sound effect 

that appeals to you. 

In the Modify Transition section, select one of the three speeds, then select 
any one of the sound effects 

Setting Timings for the slides 

Fig. 9.28 on the previous page illustrates the Advance slide timing options. The Timing options 

will allow the user to advance to the next slide either manually (by clicking the mouse) or 

automatically (after 10 seconds is our choice). 

In the Modify Transition section, click on the radio button next to 
Automatically after: and increase the Advance slide time to 10 (ten) seconds 

You are applying these Timing and Transition effects to All the slides in the presentation. But you 

should bear in mind that you could have different effects for each slide if you wanted, simply by 

going from slide to slide, setting the options, and not applying them to All Slides. 

This is only a good idea if you are designing a slide show where your goal is to impress your 

audience: 

(a) with your Impress skills; 

(b) with your artistic/creative nature; 

(c) because you actually want to distract your audience from the flow of your presentation; 

(d) because you just have no idea what you’re doing! 

So, unless you know what you’re doing, and for the sake of this exercise, let’s apply these settings 

to All Slides. 

Click on the button to Apply Transition to All Slides (see Fig. 9.28 previous 
page), then Save the slide show (Ctrl+s) 

Now would be a good time to check out the presentation. 

In the Slide Show menu select Start from First Slide and sit back and enjoy 
what you’ve made of the show to this point 
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Each slide will hold on screen for 10 seconds, which is ample time to read what’s on the slide. 

But if you want to move the show along, just click the left mouse button or tap on your touch 

pad (or your screen, if you have a touch screen) at any time. 

Hit Esc top right of the keyboard when the show ends 

Choosing a Master Slide 

Impress gives you all kinds of assistance in the design of your slides. So far we've used the basic 

set of Slide Layouts, which are OK when it comes to the general layout of each slide in your show. 

The Slide Layouts help you throw together a so-called “quick-and-dirty” Impress presentation, 

where you’ve planned what you want to “show and tell,” but you haven’t given much thought to 

how you want your show to look. 

The easiest way to make your slides more interesting is to use one of the Master Slides that 

come with Impress, or those you create yourself. You can select from a set of pre-formatted slide 

Master Slides involving graphics, colors, and animations. 

Let's check out some of these Master Slides now. 

Stay in the Slide Sorter view, make sure all the slides are selected (Ctrl+a), 
then click on the Master Slides icon in the column of icons on the right edge 
of the Impress window (Fig. 9.29) 

  

Fig. 9.29 The Impress Master Slides icon 

Hit Ctrl+a to select all the slides in the Slide Sorter view, then click on the 
various Master Slides designs to check them out 

As you click on each one, wait while Impress updates each slide with the Master Slide design. As 

you’ll quickly see, the best Master Slides for the Screenbeans slide show are those that have a 

predominantly white background because the Screenbean images are themselves black on a white 

Bright 

Blue 
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background. So, a good Master Slide for now is probably the one called Bright Blue. Let’s work 

with that. 

For the sake of the exercises that follow, click to select the Bright Blue Master 
Slide design, then Save this final version of the Screenbeans presentation 

Impress quickly applies the selected design template to all the slides in your show. 

Once again go to the Slide Show menu, select Start from first Slide and take 
a few minutes to check out the show from start to finish 

Hit Esc when you’re done 

One final word about the limitation presented by the Screenbeans all being black images on a 

white background, which restricts the number of Master Slides you can use. LibreOffice offers 

the option to “use an external program” to edit an image—for example, by making the 

background transparent. If you did this with the Screenbeans, you’d be able to use any of the 

Master Slides for your presentation. 

That being the case, if you know what you’re doing, you could, ahead of time, use a Graphics 

Design program available to you for this purpose. You’d use the program to render the 

Screenbeans as Black with a transparent background, allowing you to use any of the LibreOffice 

Master Slides, as well as design your own. 

Just a thought. We’ll be talking more about Master Slides in Lesson 10. 

 

9.5 PRINTING PRESENTATION HANDOUTS 
A nice feature of Impress is its ability to provide you with hard copy versions of the slides and/or 

of the outline text of a presentation. This is useful for the preparation of handouts for an audience 

such as a class or other lecture environment. Here are the steps to do this (learn here how to do it, 

even if you’re unable to use a printer where you are using these tutorials). 

From the File menu choose Print (Fig. 9.30) 

 

Fig. 9.28 Selecting the Handouts option for printing 
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In the Range and copies section select All slides 

In the Print section, click on the down arrow in the Document data entry box 
and, in the menu of options, select Handouts (see Fig. 9.28 above) 

In the Slides per Page box select 9 

Notice that the slides will thus be printed nine per page, three-by-three, left to right, then down. 

Click on OK if you are able to print a copy of the presentation 

This handout can then be distributed to an audience or a class for note-taking, review or 

reinforcement. 

Save this final version of the Screenbeans show then, before you finish, go 
ahead and make a backup copy of your Screenbeans presentation 

If you wanted to print the handouts in Black and White or what’s called Grayscale, in the Print 

dialog box you’d click on the LibreOffice Impress tab and click on the appropriate radio button of 

your choice. 

 

LOOKING BACK 
Lesson 9 has been devoted to the Impress program that is designed to help in the preparation of 

presentation materials of all kinds. It is not only a very useful tool, but it is also enjoyable to work 

with. Outlines and slide shows will add polish to the lessons or presentations you will prepare for 

your students and other groups during the course of your career. 

For example, a math or chemistry teacher might intersperse her lessons with professional-

looking formula charts or chemical structures. Any teacher could make an impressive graphic 

introduction to a class. An administrator could do the same for her school, the presentation to be 

viewed in the office by visitors.  

But Impress is still more valuable as a tool for learning in the hands of your students. They 

will soon learn the necessary skills to use the program with flare as they create presentations of 

their own. As their teacher, you'll guide them in the direction of learning projects of all kinds 

related to the curriculum K-12. In the context of Impress, students will discover knowledge and 

construct their own mental database of information that will stand them in good stead in their 

future lives. 

 

LOOKING FORWARD 
Impress is a useful teaching tool, providing added value for both the teacher and the students. A 

carefully prepared and well-designed presentation, appropriately used during the course of a class, 

helps the teacher stay focused and on track. A presentation that is rich in multimedia gives the 

teacher the opportunity to spice up presentations in various ways that promote added interest and 

engagement for students. Impress also can be used to create as well as enable powerful learning 

environments. 

Lesson 10 will show you how to create interactive presentations in which the user learns while 

responding to the material that is being presented, thus encouraging engagement, which promotes 

learning. More powerful yet, Impress may be best used in the discovery mode of learning, where 

the students create presentations that involve research in the pursuit of knowledge, incorporating 
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multimedia—still images, video, and sound, along with text—in the construction of a personal 

understanding of the subject matter being learned. 

A thoughtful teacher will encourage her students to work together on such projects and present 

their work to the class, thus applying the adage that the best way to learn is to teach. 

As the saying goes: "I hear and I forget, I see and I remember, I do and I understand."  

 

SKILL CONSOLIDATION 
1. Prepare a presentation on the subject of the American colonies. Make sure you have at least 

eight first level topics (eight slides), as well as a title slide and an acknowledgements slide. 

2. Prepare a presentation on the subject of US Presidents (or any subject of your choice that you 

might use with a K-12 age group appropriate to your major). Make sure you have at least eight 

first level topics (eight slides), as well as a title slide and an acknowledgements slide. 

3. Prepare a presentation on the subject of the American movie scene. Make sure you have at least 

eight first level topics (eight slides), as well as a title slide and an acknowledgements slide. 

4. Prepare a presentation in a style of your own choosing with at least three levels on the subject 

of contemporary music. Make sure you have at least eight first level topics (eight slides), as 

well as a title slide and an acknowledgements slide. 

5. Create a slide show with yourself as the subject—you the person, you the teacher. Use graphics 

drawn from any source you like. Make sure you have at least eight first level topics (eight 

slides), as well as a title slide and an acknowledgements slide. 

6. Create a slide show on the subject of pets. Use graphics from clip art or created in a Drawing 

or Painting environment. Make sure you have at least eight first level topics (eight slides), as 

well as a title slide and an acknowledgements slide. 

7. Create a slide show on the subject of geometric shapes. Use graphics drawn from clip art or 

created in a Drawing or Painting environment. Make sure you have at least eight first level 

topics (eight slides), as well as a title slide and an acknowledgements slide. 


