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7 
MAIL MERGE AND RELATED OPERATIONS 
Bringing it all together 

LEARNING OUTCOMES 
LibreOffice is an integrated suite of programs. This means that the different components of the 

Office software—Writer, Base, Calc, and Impress, for example—are all part of the same system. 

As a result, you can easily switch from one component to another, cut and paste data between 

documents and, above all, use a common set of tools with each of the applications. The steps 

required to edit, copy, arrange, print, format, cut and paste, and so forth, are more or less the same, 

whether you are in the word processor, drawing, database, spreadsheet or presentation components 

of LibreOffice. 

In Lesson 6 you were introduced to the LibreOffice Base database. In Lesson 7 you are going 

to apply what you have learned about databases to the task of creating form letters and mailing 

labels. The process is called Mail Merge and it is an important word processing skill with which 

every teacher should be familiar. 

You can merge data from a database into different types of LibreOffice documents to produce 

any number of versions of a standard document tailored to address individual recipients. 

This is especially useful when creating form letters, which are another type of template or 

stationery document. But you can also merge data into a spreadsheet (such as an invoice or other 

accounting document) or into a drawing document. You can create mailing labels, or any document 

that requires fill-in-the-blanks data. 

In this tutorial you will practice these skills by writing a form letter to your students' home 

contact (parents or guardians). A form letter is a letter which is to be circulated to a group of people 

such as parents, and into which you place data specific to each individual in the group. In other 

words, a form letter is a personalized circular letter that is customized for each individual who 

receives it. 

The first of the two letters you are going to develop will inform parents of an upcoming field 

trip. The second will report on each student's progress after five weeks of a class session. The 

Writer mail merge feature greatly simplifies the process of creating form letters of this kind. 

First, you are going to create a Calc spreadsheet, which will contain all the data you need to 

create the form letter. The next step you will complete will involve converting the Calc spreadsheet 

data source document into a Base database, and then you will merge the data that is in the database 

into a Writer form letter. This form letter will be used by Writer to control the creation and printing 

or sending (in email) of a set of customized letters to parents that will be the final product of the 

first part of this tutorial. You will also learn how to create mailing labels. 

The last part of the tutorial will step you through the process of creating a form letter using an 

already existing LibreOffice Base database. In this final exercise you will also use the Calc 

spreadsheet to create a chart that will be incorporated into the form letter. 

In this tutorial you will complete the following tasks1: 

• prepare a data source document (a LibreOffice Base database) for a form letter; 

 
1 I am indebted to Tony Palaez for his video on Mail Merge at http://www.youtube.com/watch?v=prZJ4w-q9AA 
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• create the form letter;  

• prepare a set of field trip notices; 

• prepare mailing labels; 

• prepare a new form letter using a macro and an existing data source document (a 

LibreOffice Base database). 

A caveat before you begin: You'll find it easiest to use the tutorial if you follow the directions 

carefully. On computers there are always other ways of doing things, so if you decide to wander 

off on your own, be sure you know your way back! 

Another word of advice… 

This tutorial will cover a lot of ground. You have perhaps worked through the previous six tutorials 

up to this point, so you should have considerable background using LibreOffice. For this reason, 

the directions will not be as detailed as in previous tutorials. There will be less hand-holding, so to 

speak. You will need to think, remember and, in so doing, consolidate all that you have learned. 

    

7.1 PREPARING AN ADDRESS LIST IN CALC  
Before you begin 

If you did not complete Lesson 1 of these tutorials, you will need to create a new folder to add to 

the set of folders in the Work Files for LibreOffice folder.  The new folder’s name is Data Files.  

Here are the steps to create this folder: 

Inside the Work Files for LibreOffice folder you should see three folders named Base Files, 

Impress Files, and Miscellaneous Files. You need to create a New, fourth, folder called Data Files. 

Here’s how you do this. 

In the Work Files for LibreOffice folder, right click in the white space below 
the list of the existing three folders then, in the drop-down menu (called a 
Context Menu) that pops up select New > Folder 

The system immediately creates a new, as yet unnamed, folder. 

Type Data Files for the new folder’s name, and hit the Enter/Return key on 
the keyboard 

This exercise will reinforce the skills you learned in Lessons 4, 5 and 6, while teaching you new 

LibreOffice techniques. It will show you how you can create an address list data source document 

using the Calc spreadsheet, which can then be converted into a Base database for the purpose of 

merging the data with a form letter. 

Entering the data for the Address List spreadsheet 

You are going to enter the address data for 10 records for a hypothetical class of 4th graders. With 

a real class, you would enter as many sets of address data as you have students in your class. Feel 

free, if you are a practicing teacher, to add as many records as you need. You will shortly be 

merging this data with a form letter. Later you’ll be using an already existing database to create 

form letters for a larger class of students.  

Open LibreOffice > Create: > Calc Spreadsheet, then go to File > Save 
As…, navigate to the Work Files for LibreOffice > Data Files > Spreadsheet 
Documents, type Address List for Grade 4 2020 and click on Save 
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Hit Ctrl+a to select all the cells in the spreadsheet, go to Format > Rows > 
Height…, in the Row Height dialog box, enter the value 0.20”, and click on 
OK 

With all the cells in the spreadsheet selected, go to Format > Columns > 
Width…, in the Column Width dialog box, enter 1.50”, then click on OK 

Click in cell A1, then across the first row (row 1) of the new spreadsheet enter 
the following eight (8) column headers: 

Header for Column A ID 

Header for Column B Home Contact 

Header for Column C Student First Name 

Header for Column D Student Last Name 

Header for Column E Address Line 1 

Header for Column F City 

Header for Column G State 

Header for Column H Postal Code 

When you are done, the column headers in your spreadsheet should look like Figure 7.1. 

 

Fig. 7.1 Naming the column headers for the data source document 

The ID field (column A) will start with the value 1 (one) and increase by 1 for each record (this 

will be the Primary Key when you convert the spreadsheet into a Base database). 

Type in the data for the first record—starting with the value 1 for the ID; then 
make up data for each of the other fields in the appropriate column of the 
spreadsheet, starting in column B with the Home Contact (the name of the 
student’s parents or other guardian—Mr. and Mrs. Brown, for example) 

After the first (Home Contact) entry, hit Tab, then type a Student First Name, 
and so on across the spreadsheet row 

After you type in the Postal Code, the last entry for the first record, click in 
the ID field for record #2, enter the ID value 2, and carry on entering 
appropriate data till you have entered the data for all 10 records 

After you have entered the data for at least ten records, your spreadsheet will 
look something like Fig. 7.2 

 

Fig. 7.2 Address List with 10 records 

Very important! Be sure to Save (Ctrl+s) the Address List for Grade 4 2020 
spreadsheet with the data that you have so carefully filled in, then Close the 
Address List for Grade 4 spreadsheet 
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7.2 CONVERTING THE CALC SPREADSHEET TO A BASE DATABASE 
The next step in our mail merge process involves converting the Address List for Grade 4 2020 

spreadsheet, which you just created, into a Base database data source object—which is necessary 

if you want to merge the data source with a Writer form letter. Here are the steps to do this. 

In the top level LibreOffice menu, in the File menu select New and, in the 
menu of LibreOffice applications, select Database (Fig. 7.3) 

  

Fig. 7.3 Opening a new database 

This will bring up the Database Wizard (Fig. 7.4). 

  

Fig. 7.4 The LibreOffice Database Wizard 
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In Step 1 of the Wizard (Select Database), click to select the radio button 
next to Connect to an existing database (Fig. 7.4 above), then click on the 
down arrow in the accompanying data box and, from the list of different 
application types, select Spreadsheet (again see Fig. 7.4 above) 

Why is a spreadsheet considered a database? Well, a spreadsheet is a data source document (it 

contains data that you want to use, so in that sense a Calc spreadsheet is a database and can be 

converted to a Base database. So, you are importing the data in the Address List for Grade 4 2020 

spreadsheet into a Table in a new database. 

Click on Next > and in Step 2 (Set up Writer Document or Spreadsheet 
connection—Fig. 7.5), click on Browse and, in the Open dialog box, navigate 
to your Work Files for LibreOffice > Data Files > Spreadsheet Documents 
folder, and double click on Address List for Grade 4 2020 to put it in the 
Location and file name data box (Fig. 7.5) 

 

Fig. 7.5 Setting up a Spreadsheet connection 

Click on Next >, then in Step 3 of the Wizard (Save and Proceed), keep the 
default selections—Yes, register the database for me and Open the 
database for editing (Fig. 7.6) then click on Finish 

 

Fig. 7.6 Final step in converting the Address List data source to a Base database 
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If you do not register the database it will not be visible to any other LibreOffice documents, 

such as the Letters document you are going to use soon for the Form Letter. 

The Wizard will now display the Save As dialog box (Fig. 7.7) to prompt you to Save the new 

database in your Work Files for LibreOffice > Data Files > Base Documents folder 

 

Fig. 7.7 Save As dialog box 

Name the new database Address List and click on Save 

The new Base database will open on your screen with a Table named Sheet1 (Fig. 7.8). 

  

Fig. 7.8 The data source uploaded to the new Address List Base database 
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With Tables selected in the Database frame (Fig. 7.8 above), double click on 
Sheet1 (see Fig. 7.8) to open the imported Table so that you can check that 
the Address List data has been correctly imported from the spreadsheet you 
created at the beginning of this exercise (Fig. 7.9) 

 

Fig. 7.9 The Address List imported to the Base database 

Your data, of course, will be different. Assuming everything looks good, you are ready to 

proceed with the next step in the mail merge process, which involves the creation of the Form 

Letter. 

 

7.3 CREATING THE FORM LETTER (THE FIELD TRIP NOTICE) 
You are going to create a letter to the parents of your students announcing an upcoming field trip, 

which you will call Field Trip Notice, into which will be merged the records that you have prepared 

in the Address List database. 

Fig. 7.11 on the next page shows the complete contents of this Field Trip Notice letter. Don't 

start typing it just yet—carefully read the directions here and on the ensuing pages in order to 

avoid making mistakes. 

You’ll begin by opening, and renaming, a Writer template document called Letters, which is 

already stored in the Work Files for LibreOffice folder on your disk drive. You should have the 

Address List > Sheet1 Table still open on your desktop. 

In the File menu select Open, then navigate to your disk drive > Work Files 
for LibreOffice > Miscellaneous Files > Merge Documents, and double 
click on the Letters document (it’s a Letters template) to open it (Fig. 7.10) 

 

Fig. 7.10 The Letters template 

Now, in the File menu select Save As…, navigate to the Work Files for 
LibreOffice > Data Files > Writer Documents folder, type Field Trip Notice 
for the new document name, then click on Save 
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You are now almost ready to use Writer’s mail merge tools to produce customized, that is to 

say individualized, letters to send to the parents or guardians of each student in your class. In Fig. 

7.11 below, the placeholders (shown shaded and enclosed by the < … > symbols) indicate the 

place in the form letter where data from the Address List database will be merged with each of the 

letters in order to personalize them. 

DO NOT START TYPING YET! The exercises on Page 249 that follow Fig. 

7.11 will take you step-by-step through the process. Follow the steps carefully. 

 

Fig. 7.11 Final version of the Field Trip Notice form letter (showing place holder merge fields) 
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Inserting the date 

The basic Field Trip Notice document is open on your screen containing the bare bones of the form 

letter (the school address at the top, the beginning of the salutation “Dear”, and the conclusion 

(Yours sincerely, etc.). 

You need to put the Date at the top of your Field Trip Notice document, immediately after the 

official address of the school where, in a real situation, you might be a teacher. 

Position the cursor on the blank line immediately after the address at the top 
of the page then, in the Insert menu, select Field > Date 

You should now have the date displayed in your form letter right after the school address at 

the top of the page (Fig. 7.11 previous page). You’ll recall from Lesson 1 that the default all-

numeric format for the date can be confusing in some countries, so you need an unambiguous date 

format. 

Right click on the inserted date and, in the Context Menu, select Edit 
Fields… then, in the Edit Fields dialog box, in the second (Select) column, 
click on Date—not Date (fixed) 

In the Edit Fields dialog box > Format column, click on the date format that 
looks like Friday, December 31, 1999, then click on OK 

The date won’t be fixed, which means that each time you open the Field Trip Notice it will 

have the current date displayed without your needing to update it. That takes care of the date 

format. 

Viewing the Data Source for the Field Trip Notice 

Now it’s time to connect your Field Trip Notice to the Address List database that you created in 

the previous exercises (Sections 7.1 and 7.2 of this tutorial). 

In the View menu, select Data Sources 

You should now have a new frame at the top of the Field Trip Notice page showing, on the 

left, a list of the Base databases that you have registered with LibreOffice (Fig. 7.12)—your list 

may be different. 

 

Fig. 7.12 Viewing the LibreOffice list of Data Sources 
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Address List is the database you want to use with the Field Trip Notice. 

In the list of registered databases, click on the small + (plus sign) to the 
immediate left of Address List to show Queries and Tables, then click on the 
small + (plus sign) to the immediate left of Tables to show Sheet1 (Fig. 7.13) 

 

Fig. 7.13 Address List Queries and Tables (Sheet 1) 

Sheet1 contains the data that you imported into the database from the Address List spreadsheet 

you created in Sections 7.1 and 7.2 of this tutorial. 

Click at left on Sheet1 and wait while LibreOffice fetches all the data from the 
Sheet1 table and displays it in the data source document window of the Field 
Trip Notice (Fig. 7.13 above) 

The data in the Sheet1 table is displayed in the window above the form letter and to the right 

of the list of registered databases (Fig. 7.13 above). 

Now comes the tricky (but neat!) part of the mail merge process. 

Inserting fields (placeholders) into your form letter   

You are going to insert into the form letter the first set of placeholders—for the receiver's 

(recipient’s) name and address—the receiver is the parent or guardian of one of your students. 

The receiver's address, after your own (school) address at the top of the letter, will start with 

the Home Contact field. So, you need to tell Writer to merge the form letter with the corresponding 

Home Contact data from the Address List database. Here is how you do this. 

The Field Trip Notice form letter should still be open on your screen (it’s the 
active document and you should still be able to see its window) 

Click on Sheet1 to 

open the Address List 

data source document 
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In the Field Trip Notice form letter, position the cursor on the empty line 
between  the Date and the salutation: "Dear", then press Enter to space down 
one more line, so you have two empty lines before the salutation (Fig. 7.14) 

 

Fig. 7.14 Space down to give two empty lines before the salutation 

Now, use the mouse to drag the title Home Contact down to the correct 
position (called a placeholder) for the Home Contact merge field in the first 
line of the recipient’s address (immediately above the salutation: "Dear", as 
shown in Fig. 7.15) 

 

Fig. 7.15 Dragging the Home Contact merge field down into the form letter 

Writer quickly displays <Home Contact> (with the brackets around it) in the body of the form 

letter immediately above the salutation “Dear”. The brackets tell you that this is a placeholder—

you never need to type the brackets with Mail Merge. 

Position the mouse pointer on 

the Title of the Home Contact 

field and drag it DOWN to the 

correct position (called a place 

holder) for the Home Contact 

merge field in the recipient’s 

address 

The cursor is now waiting 

here 
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Now, when the letters (all ten of them) are eventually printed out, the correct name of each 

student’s parent or guardian will be copied from the Address List database and inserted into this 

position (place holder) in the letter. 

Next you need to add the rest of the Home Contact’s address (if necessary, refer to Fig. 7.11 

on page 248). 

The cursor should be waiting at the end of <Home Contact>, so press the 
Enter key to move to a new line 

Once again, use the mouse to drag the title Address Line 1 down to the correct 
position on the new line after <Home Contact>, which will be the second line 
of the form letter recipient’s address 

Writer adds the new merge field to the address. 

Press the Enter key to move to a new line, use the mouse to drag the title City 
down to the correct position on the new line after <Address Line 1>, which 
will be the last line of the form letter recipient’s address 

Now stay on the same line, type a comma (,) followed by a space, and use 
the mouse to drag the title State down to the correct position (after the City) on 
the last line of the recipient’s address 

Hit the space bar once, use the mouse to drag the title Postal Code down to 
the correct position at the end the last line of the recipient’s (Home Contact’s) 
address, hit the Enter key to move the cursor to the next line, then hit the Enter 
key again so that there will be an empty line after the address (Fig. 7.15 below) 

This rounds off the Recipient’s (Home Contact) address that is to be merged with the Field 

Trip Notice form letter, which should now look like Fig. 7.16. 

 

Fig. 7.16 Form letter after merging the recipient’s address 

So far, so good. Next you need to put a placeholder for the Home Contact immediately after 

the salutation Dear at the beginning of the letter (if necessary, refer again to Fig. 7.11 on page 

248). 
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Click to put the cursor immediately after the word Dear 

Press the Space bar to space over one space, then use the mouse to drag 
the title Home Contact down to the correct position after the salutation Dear 

Type a comma, then hit the Enter key 

By now you should be getting the hang of inserting merge fields into the Field Trip Notice. 

Refer to the Field Trip Notice letter (Fig. 7.11 on page 248) as you complete 
the rest of the form letter 

Type the remaining text of the Field Trip Notice letter illustrated in Fig. 7.11 
on page 248, inserting the merge placeholders where indicated 

Where necessary, be sure to put a space before and/or after each 
Placeholder so that the data will be correctly spaced in the final version of the 
letter 

When you’re done, Save the Field Trip Notice form letter (Ctrl+s) once more 

 

7.4 PRINTING THE FIELD TRIP NOTICE MERGED LETTERS 
Before printing your Field Trip Notice merged letters on paper (hard copy), it’s always a good idea 

to preview them on the screen (soft copy), with the appropriate data filled in for each version of 

the letter.  This will allow you to confirm that the data from the Address List source document has 

been correctly merged with the Field Trip Notice form letter.  It will also enable you to check out 

on the screen the complete set of 10 merge letters, scrolling through them all one after the other. 

In LibreOffice, this is all part of the Print function. 

From the File menu select Print… 

LibreOffice immediately recognizes that the Field Trip Notice document contains Address List 

database fields and asks you to confirm that you want to print a form letter (Fig. 7.17). 

  

Fig. 7.17 Prompt to confirm it is a Form Letter 

Click on Yes 
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You’ll be presented with the Mail Merge dialog box (Fig. 7.18), which helps you set up the 

desired output for the Field Trip Notice. 

 

Fig. 7.18 Mail Merge dialog box 

You do not want the output to go to the Printer just yet.  Instead, you want the output to go to 

a File. 

You also want to save the merged document as a single document which will contain all 10 of 

the Field Trip Notices, each one individually tailored to the Home Contact of a different student 

in the class. 

Here’s what you do to make this happen. 

In the Output area of the dialog box (Fig. 7.18 above), click on the radio button 
next to File to select that option 

Leave selected the radio button next to Save as single document, then click 
on OK 
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LibreOffice now displays the Save As dialog box, prompting you to Name the Field Trip Notice 

merge file and decide where you want to save it (Fig. 7.19). 

 

Fig. 7.19 Saving the Field Trip Notice Merge Letters 

In the Save As dialog box, navigate on your disk drive to your Work Files for 
LibreOffice > Data Files > Writer Documents folder Fig. 7.19 above) 

In the File name: data entry box, type Field Trip Notice Merge Letters, click 
on Save and wait while LibreOffice saves the set of letters in the Data Files > 
Writer Documents folder 

The document Field Trip Notice Merged Letters is several pages long—at least 10 if each letter 

fits on one page, but 20 if each letter flows over onto a second page. Saving the complete set of 

merged letters is a good idea. It means that you have a copy of the final version of the updated 

letters for your records—a customary practice with regard to professional correspondence. 

Previewing your letters on screen 

You’re nearly there. But first you need to take a look at the Field Trip Notice Merge Letters 

document to check that the data from the Address List has been correctly merged with the 

placeholders in the new document (Field Trip Notice Merge Letters). 

Go to File > Open and double click to open the Field Trip Notice Merge 
Letters 

This document contains all ten of the field trip notices, so scroll through to 
the end to check (a) that there are indeed 10 letters (or however many records 
you entered into the Address List database) and (b) that each letter has the 
appropriate merged data 
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Notice how the data from the Address List has been merged into each of the letters, giving 

each letter a personalized appearance (Fig. 7.20). 

  

Fig. 7.20 The Field Trip Notice Merged Letters 

Editing (further personalizing) the recipients’ letters 

At this stage, you could do some final editing of the individual letters (the Field Trip Notices), 

prior to printing them as hard copy. The set of notices are all saved in one file and you can “visit” 

each letter and add a comment here or there which pertains to a particular student or the Home 

Contact. 

For example, you could add a sentence to each letter saying something special about the 

student. This would further individualize the letters, giving parents the sense that the letter they 

receive is unique to them. In this way you can further personalize what is, in fact, a form letter. 

This is always a good thing to do, if you have the time. 

After you have checked all ten of the Field Trip notices, and made any final 
edits or personal touches you want, Save again the Field Trip Notice Merge 
Letters document 
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Printing the merged Field Trip Notices 

If you are able to print the set of 10 merged letters you can go ahead and do so now. 

Go to File > Print, then in the Print dialog box select any options that are 
necessary for your printer setup and, when you’re ready, click on OK 

When the set of Merge Letters are all printed, Close the Field Trip Notice 
Merge Letters document, and Close the Field Trip Notice, but keep open the 
Address List database, along with its Sheet1 Table—you’re going to need 
them for the next exercise 

A summary of the Writer Mail Merge features 

• You can insert the fields from the Address List database into the merge document (in our 

case the Field Trip Notice) in any order. 

• You can put more than one field in a line or in a paragraph, and you can mix punctuation 

or other words or characters in amongst the fields. For example, you put City, State, and 

Postal Code on the same line, and you can insert a comma between the City and State fields. 

• You can repeat the use of a field in a document. You put this feature into effect when you 

repeated the Home Contact field, once at the beginning of the receiver's address, and again 

in the salutation. You also repeated the First Name field several times. 

• You can put together an entire document containing only the data stored in the database. 

You don't have to include any other text. 

Mail merge is a powerful productivity tool. It takes planning, and a certain amount of work up 

front (which gets easier the more you do it), but it is obviously quicker than writing individual 

letters to the parents of a class of 20 to 30 students. 

The more students you have in a class, the greater the productivity gain—though this is no 

argument for large class sizes! Plus, you can use the original form letter for generations of classes, 

year after year. 

And don't forget that your students can help you plan and produce form letters, even when the 

contents may eventually contain privileged information. The tough part of the Mail Merge task is 

assembling the data. Your students will be happy to enter relevant data into the database. This data 

might include parent's names and addresses, for example, plus their own first and last names and 

any other useful info such as hobbies, and so forth. 

Running off the letters then takes little effort on your part. Confidentiality is important, so you 

might run off the letters when the students are not around. However, as a rule it is to everyone's 

advantage when you involve students in such tasks. It develops their sense of responsibility and 

increases their awareness that they are part of the process of education—not just victims of it! 

 

7.5 PREPARING MAILING LABELS 
Mailing labels are like those Return-Address stickers you put on the outside of your envelopes, or 

those address stickers that you often find on mass-mailed items that you receive in the mail. 

Producing them is simple enough, especially if you have completed all the tutorials up to this point. 

Deciding on the data for the mailing label 

Writer Merge documents, such as mailing labels, are always linked to a database. You’ll use the 

Address List database you created for the Field Trip Notice form letter. You know by now how to 

create your own database of addresses (see sections 7.1 and 7.2 in this Tutorial). 
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So, you could create an address list of your own; in fact, you may well already have an 

electronic address list which you could, if you wanted, use for this exercise. 

First you need to open a new Labels document. 

With the Sheet1 > Address List as the active window on your desktop, go to 
File > New > Labels (Fig. 7.21) 

 

Fig. 7.21 File > New > Labels menu 

You should see the Labels dialog box on your screen (Fig. 7.22). 

 

Fig. 7.22 The Labels dialog box (annoated) 

After you select each field from the Address 

List Database, click on this arrow to transfer 

them one by one to the Label text area 

Click here to accept the 

Labels settings 
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As illustrated in Fig. 7.22 on the previous page, in the Labels dialog box you are going to make 

selections in the Database, Table, and Database field data entry boxes in order to move into the 

Label Text box a complete set of Address List database fields for the Home Contact address. 

You also have to select the Brand and Type of mailing label you want to use, again as 

highlighted in Fig. 7.22 on the previous page, which shows the Labels dialog box after you have 

completed these tasks. 

The following directions will step you through this process of filling out the Labels dialog box; 

follow them carefully. Notice, in Fig. 7.22, that you are going to lay out the Recipient address as 

it would appear on an envelope—as a mailing label. 

In the Labels dialog box > Database: item, click on the down arrow at the end 
of the data entry box and, from the list of databases, select Address List 

In the Labels dialog box > Table: item, click on the down arrow at the end of 
the data entry box and, from the list of Tables, select Sheet1 

Next you have to set up the layout for the recipient (Home Contact) address for the mailing 

label. 

In the Labels dialog box > Database Field: item, click on the down arrow at 
the end of the data entry box and, from the list of database fields, select Home 
Contact, then click on the large arrow to transfer the Home Contact 
field across to the Label Text: area 

Click on the Enter key to move the cursor to a new line in the Label Text: area 

Again, in the Labels dialog box > Database Field: item, click on the down 
arrow at the end of the data entry box and, from the list of database fields, 
select Address Line 1, then click on the large arrow        to transfer the 
Address Line 1 field to the Label Text: area 

Click on the Enter key to move the cursor to a new line in the Label Text: area  

Again, in the Labels dialog box > Database Field: item, click on the down 
arrow and, from the list of database fields, select City, then once again 
transfer the City field by clicking on the large arrow       

Type a comma after the City field, and hit the space bar 

In the Labels dialog box > Database Field: item, click on the down arrow and, 
from the list of database fields, select State, then transfer the State field 
across to the Label Text: area by clicking on the large arrow 

Hit the space bar to space after the State field  

In the Labels dialog box > Database Field: item, click on the down arrow and, 
from the list of database fields, select Postal Code, and click on the large 
arrow        one last time to transfer the Postal Code field across to the Label 
Text: area 
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Hopefully, you were able to follow all those directions and, with the aid of Fig. 7.22, you 

successfully completed the tasks to this point. There are a couple more things you have still to do 

in this Labels dialog box. 

Selecting the standard format for the mailing label 

The mailing labels are now ready to be filled with the database fields; all that remains is to tell 

LibreOffice what standard format you want them to have for your Field Trip Notices envelopes. 

We’re going to go with Avery A4 for the Brand and C2160 Avery Inkjet Label for the Type. 

But the label format doesn’t have to be Avery A4, of course. If you already have sheets of mailing 

labels that you intend to use for this exercise, check out the box they come in and look for the 

Company Brand and Type of label. Then look up the appropriate Brand and Label Type in the 

menus that pop up when you click on the down arrows for the respective data entry boxes. 

So, for your own purposes you can select any option you like; otherwise, for the sake of this 

tutorial go with the selections that follow for now. 

In the Format area of the Labels dialog box (Fig. 7.22 on page 258), make 
sure the radio button next to Sheet is already selected 

In the Brand: data entry box, check to see that the default Avery A4  is already 
selected, otherwise click on the down arrow to bring up the menu of standard 
company mailing label formats and select the Avery A4 option 

Next, in the Type: data entry box, check to see that the default C2160 Avery 
Inkjet Label, otherwise click on the down arrow to bring up the menu of 
standard mailing label Types and select the C2160 Avery Inkjet Label option 

In the Labels dialog box click on the Options tab (Fig. 7.23) to bring up the 
Options dialog 

 

Fig. 7.23 Options tab in the Labels dialog box 
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Make sure the radio button for Entire page is selected and that there is a 
check mark/tick next to Synchronize contents to ensure that all the labels 
are merged with the Address List database 

Finally click on New Document 

Immediately, LibreOffice presents a sheet of mailing labels with all the database fields laid out 

as per the design you specified in the Labels dialog box (Fig. 7.24). 

  

Fig. 7.24 The template mailing labels sheet 

Click on the Synchronize Labels button (Fig 7.24 above), then go to File > 
Save As…, navigate on your disk drive to the Work Files for LibreOffice > 
Data Files > Writer Documents folder and Save the new document with the 
name Field Trip Notice Merged Mailing Labels 

Previewing your mailing labels on screen 

Now you are ready to go ahead and preview the sheet of mailing labels with all the data from the 

database, which you should always do before sending them to the printer. 

From the File menu select Print 

Click here to 

Synchronize all the 

mailing labels with the 

data in the Address List 

database 
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As before, LibreOffice immediately recognizes that the Field Trip Notice Merged Mailing 

Labels document contains Address List database fields and asks you to confirm that you want to 

print a form letter (Fig. 7.25). 

 

Fig. 7.25 Request to print a form letter 

Click on Yes  

After a few seconds, you are presented with the Mail Merge dialog box (Fig. 7.26). 

  

Fig. 7.26 Mail Merge dialog box 

You want the output to go to a File. You also want to save the merged document as a single 

document which will contain all 10 of the Field Trip Notice Mailing Labels, each one individually 

tailored to the Home Contact of a different student in the class. 
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Click on the radio button next to File to send the output to a File, and leave 
the radio button next to Save as single document selected (Fig. 7.26 above) 
then click on OK 

LibreOffice now displays the Save As dialog box, prompting you to Name the merge file and 

decide where you want to save it. 

In the Save As dialog box, if necessary navigate to your LibreOffice Work 
Files > Data Files > Writer Documents folder, then, in the File name: data 
entry box, type Field Trip Notice Merged Mailing Labels Printout file and 
click on the Save button 

As noted above, it’s always a good idea to check out the Field Trip Notice Mailing Labels to 

check that the data from the Address List has been correctly merged with the file. 

Go to File > Open and double click on the Field Trip Notice Merged Mailing 
Labels Printout File to Open it 

Notice how the data from the Address List has been merged into each of the mailing labels, 

giving each label a customized look (Fig. 7.27). 

 

Fig. 7.27 The Field Trip Notice Merged Mailing Labels 
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Check out the layout and content of the mailing labels. If you had many addresses in your 

Address List you might need to scroll to check them all out, or you could check out individual 

addresses by clicking on Ctrl+f to Find a recipient. This isn't necessary for this exercise since you 

have only a few (10) names and addresses in your Address List. 

You don’t need the Field Trip Notice Mailing Labels file for the exercise that 
follows, so go ahead and Close it, but keep open the document Field Trip 
Notice Merged Mailing Labels Printout File 

Printing the mailing labels 

If you intend to print the mailing labels, click on File > Print > OK… and Writer 
will print the mailing label sheet(s) 

Close the Field Trip Notice Merged Mailing Labels Printout File document 

 

7.6 PREPARING A NEW FORM LETTER USING AN EXISTING DATABASE 
By way of reinforcement of what you have learned in this lesson, let’s prepare another form letter. 

This time we’ll an existing database. In your Work Files for LibreOffice > Miscellaneous 

Documents > Merge Documents folder there is a database called Fall Roster 2020. It is a set of 

records for a sample class of 25 students. 

You are going to use the data in the Fall Roster 2020 database to prepare a form letter called 

Mid Term Report, which will report to parents/guardians on their child’s progress-to-date half-way 

through a Semester/Term. 

You are then going to have Writer merge the Mid Term Report with the Fall Roster 2020 

database. 

But first you need to open a Writer template as a basis for the report. The template is called 

Letters. 

Your Address List database, along with its Sheet1 Table, should still be open 
on your desktop, so go to File > Open, navigate to your disk drive > Work 
Files for LibreOffice > Miscellaneous Files > Merge Documents then 
double click to open the Letters Writer document 

Registering the Fall Roster 2020 database 

You need to register the Fall Roster 2020 database with LibreOffice before you can use it to merge 

its data into the Letters merge document. Here are the steps to do this. 

Go to the Tools menu > Options…, then, in the left-hand frame of the 
Options window (Fig. 7.28 next page), click on the “+” sign next to LibreOffice 
Base to show the items in the LibreOffice Base sublist, and click on 
Databases 

In the right-hand frame, in the Registered databases section, click on 
Address List to highlight it (Fig. 7.28 next page), then click on New 
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Fig. 7.28 The Tools > Options > LibreOffice Base > Databases dialog box 

This brings up the Create Database Link dialog box (Fig. 7.29). 

  

Fig. 7.28 Create Database Link dialog box 

In the Create Database Link dialog box, click on Browse and navigate to 
your disk drive > Work files for LibreOffice > Miscellaneous Files > Merge 
Documents, then double click on Fall Roster 2020 to put it in the Registered 
name data entry box (Fig. 7.28 above), then click on OK 

Make sure Address List 

is selected (highlighted) 
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Notice that the Fall Roster 2020 database is now in the Registered Name list in the Registered 

Databases section of the Options dialog box (Fig. 7.29). 

 

Fig. 7.29 Adding Roster 2020 to the list of registered databases 

Click on OK to complete the registration of the Fall Roster 2020 database 

The Fall Roster 2020 database is now a registered database and may be used as a data source 

for the Letters document you are working with and which should still be open on your screen. 

In the View menu select Data Sources, then in the list of databases at top-
left of the Letters window scroll down, if necessary, till you see Fall Roster 
2020 

Now click on the + (plus sign) next to Fall Roster 2020 and again scroll 
down if necessary, then click on the + (plus sign) next to Tables to bring up 
the Fall Roster 2020 Table 

Again scroll down if necessary, then click once on Fall Roster 2020 Table, 
then wait while the data from the Fall Roster 2020 database is displayed in 
the top-right pane of the Letters window (Fig. 7.30 next) 
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Fig. 7.30 The Roster 2020 data displayed top right of the Letters window 

Creating the Mid Term Report form letter 

Next you are going to use the Letters document, which came with the Work Files for LibreOffice, 

to create a Mid Term Report which will go out to the parents of your students. The report is 

illustrated in Fig. 7.31 on the next page. 

 

Do NOT start typing the report yet! 

 

You have a couple of other things to do to get set up for the mail merge. 

First you must save the Letters document with a different name so that you will keep the copy 

of the Letters document as a template for future use. 

Go to File > Save As, navigate to your disk drive > Work Files for LibreOffice 
> Data Files > Writer Documents folder 

Change the name of the Letters document to Mid Term Report (this will be 
the name of the form letter you are going to create) 

Next, navigate again to your disk drive > Work Files for LibreOffice > Data 
Files > Writer Documents folder and click on Save 

You are going to have Writer produce one letter for each student in the Fall Roster 2020 class. 

As you can see, the form letter illustrated in Fig. 7.31 on the next page reports to parents on how 

well their child is doing half-way through the semester. 

You already told Writer that you want to merge the form letter with the data stored in the Fall 

Roster 2020 database. The placeholders in Fig. 7.31 (where the field names are enclosed by the 

<…> brackets) indicate the location in the form letter where data from the Fall Roster 2020 

database is to be merged when the letters are actually printed out. 

Wherever you see a placeholder (<…>), use the mouse to drag the appropriate field header 

down from the data displayed top right as you work your way through the letter. 

You already completed a similar exercise earlier in this lesson. 

If you are still unsure about what to do, you might like to check back at what you did—section 

7.3 Creating the form letter (the Field Trip Notice), starting on page 247. 
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Fig. 7.31a The Mid Term Report form letter showing location of all placeholders 

All that remains is for you to create the Mid Term Report form letter as illustrated in Fig. 7.31a. 

Type in the text and insert the placeholders for the various individualized data items in the 

letter, such as each student’s first name, family home contact information, and so forth, as 

illustrated in Fig. 7.31a above. These individualized data items are accessed from the student 

records you already created and stored in the Fall Roster 2020 database. 

If you need help completing this task, refer back to the section on page 250 of this tutorial titled 

Inserting fields (placeholders) into your form letter. Fig. 7.15 on page 251 is especially useful as 

a guide for what you need to do. 

If the text in Fig. 7.31a is too small for you to easily read, refer to Fig. 7.31b on the next 

page, where a larger typeface is used; the content is otherwise identical. 
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Fig. 7.31b More readable version of the Mid Term Report 

Start with creating the placeholders for the full recipients’ address (Home 
Contact, Address Line 1, City, State and Postal code)—when you’re filling 
out the recipient’s address be sure to hit Enter where necessary to start a 
new line, and add a comma after the City data item and spaces before the 
State and Postal code, as required in any address 

Be sure to use the Date format illustrated in Figs. 7.31a/b—Insert menu> 
Field > Date, double click on the Date that is inserted into the report, then, if 
necessary, in the pop-up Context Menu of Edit Fields…, in the Select column 
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click on the Date option—NOT Date(fixed)—then in the Format column select 
the Friday, December 31, 1999 style, and click on OK 

As you are entering the text for the Midterm Report, where indicated in Fig. 
7.31a/b, insert the various other placeholders in the form letter (First Name, 
Grade, ATD and Comment) 

When you are done typing up the full contents of the Mid Term Report form 
letter, including the various placeholders as illustrated in Figs. 7.31a/b on the 
previous pages, Save the Mid Term Report 

Pasting a chart into the Mid Term Report form letter 

The letter needs one final touch. You are going to put a chart in the Mid Term Report. You will 

create the chart in a Calc spreadsheet, then copy it into the Mid Term Report. It’s easy to do if you 

already completed the Calc tutorials in this ESSENTIAL LibreOffice book (Lessons 4 and 5). 

Go to File > Open…, navigate to your disk drive > Work Files for LibreOffice 
> Miscellaneous Files > Merge documents and double click on the 
Gradedata spreadsheet to open it 

You are going to create a simple chart using the data in the Gradedata spreadsheet. This will 

be useful reinforcement of what you learned in Lesson 5. Here are the steps, if you need help. 

Highlight cells A1 through B6 (the data that will be represented in the chart), 
then go to Insert > Chart… (Fig. 7.32) 

  

Fig. 7.32 Selecting the Chart option in Calc 
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LibreOffice Calc immediately creates a default Column chart based on the data in the 

spreadsheet, and also presents the Chart Wizard dialog box (Fig. 7.33) which will help you create 

a more interesting or, more to the point, more meaningful chart. 

 

Fig. 7.33 Default Column Chart and the Chart Wizard dialog box 

Use the mouse to grab the Chart Wizard dialog box in the white space at the 
top of the box and drag it down to uncover the Chart (see Fig. 7.33 above) 

You need to create a Pie Chart to go into the Mid Term Report Writer document. 

Start, in Step 1, by selecting the Pie chart option, click on the first Normal Pie 
Chart design, then click to put a check/tick in the check box next to 3D Look 
and click on Next (Fig. 7.34) 

  

Fig. 7.34 The Chart Wizard dialog box 

Grab the Chart 

Wizard dialog box 

by the white space at 

the top of the box 

and drag it down  

below the Pie Chart 
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Calc quickly assembles the chart and displays it on the screen (notice the small handles around 

the chart indicating that it is a selected object)—Fig. 7.34. 

 

Fig. 7.35 Basic 3D Pie chart for the Grade 4 Reporting Period  

As charts go, it’s pretty plain at this stage, and not too meaningful. The chart needs a title and 

subtitle, and each of the slices need numerical values associated with them. Fig. 7.36 illustrates 

what we’re looking for in the final version of the chart. 

 

Fig. 7.36 Final version of the Grade 4 grading period data chart 

Essentially, a chart like this is an opportunity to create “a picture worth a thousand words.” 

And the LibreOffice suite of productivity software does a good job of making this possible with 

little effort on your part. 

Let’s do what is necessary to arrive at this final version of the chart. We don’t need to do 

anything with Steps 2 (Data Range) and 3 (Data Series) of the Chart Wizard since you already set 

Chart handles 

Chart Titles 

This is the Legend, 

which explains what each 

slice of the pie refers to: 

Blue for A Grades, 

Orange for B Grades, 

Yellow for C Grades, 

Green for D Grades, and 

Plum for E/F Grades 
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the data range when you selected the set of cells containing the data for the chart and our data 

sample is very simple. 

So… On to Step 4. Chart Elements. 

In the left-hand frame of the Chart Wizard dialog box click on Step 4 to bring 
up the Chart Wizard > Chart Elements dialog (Fig. 7.37) 

 

Fig. 7.37 The Chart Wizard > Chart Elements dialog 

Go ahead and type in the Title: Grade Data, Grade 4, Reporting Period 1, 
then type in the Subtitle: August 18 – September 26, 2020 and click on Finish 

Next, let’s change the font of the Title and Subtitle text. 

Double click anywhere on the Title text (Grade Data Grade 4, Reporting 
Period 1) to put a blue box around it, then triple click on the Title text to select 
it (Fig. 7.38) 

  

Fig. 7.38 Selected Title text 
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Right click anywhere in the Title Text box and, in the Context Menu that pops 
up, select Format Title… to bring up the Main Title dialog box (Fig. 7.39) 

 

Fig. 7.39 Formatting the Chart Title 

In the Main Title dialog box, click on the Font tab and, in the Font menu, scroll 
to select Comic Sans MS, in the Style menu select Bold, and in the Size 
menu select 16, then click on OK 

Now click once on the Main Title of the chart to show the blue border with the 
handles around it, hit the arrow keys on the keyboard to slide the box up to 
the top of the Chart window and to center the title over the chart, then click 
outside the box 

You need to do the same for the Subtitle text: August 18 – September 26, 2016. 

Double click anywhere on the Subtitle to put a blue box around it, then triple 
click on the Subtitle to select ALL of the text and the box around it 

Now, right click anywhere in the Subtitle Text box and, in the Context Menu 
that pops up, again select Format Title… to bring up the Subtitle dialog box 
(much the same as Fig. 7.39 above) 
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In the Subtitle dialog box, click on the Font tab and, in the Font menu, scroll 
to select Comic Sans MS, in the Style menu select Regular, and in the Size 
menu select 12 pt, then click on OK 

Now click once again on the blue border of the Subtitle dialog box to show it 
with the handles around it, then hit the up-arrow key on the keyboard to slide 
the box up till it’s just below the Main Title box, then click outside the box 

Your chart should now look like Fig. 7.40. 

 

Fig. 7.40 Pie chart with Titles formatted 

That takes care of the chart titles. All that remains is to put labels on each of the slices in the 

Pie Chart to help the reader of the Mid Term Report interpret the data in the chart.  

Right click anywhere on the Pie Chart itself (on one of the slices in the pie) 
and, in the Context Menu that pops us, select Insert Data Labels (Fig. 7.41) 

  

Fig. 7.41 Right click on the Pie in the chart box 
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Notice that LibreOffice updates each slice of the Pie Chart with the value (number) from the 

Gradedata spreadsheet that corresponds to each of the Grades—A, B, C, D, or E/F (Fig. 7.42). 

   

Fig. 7.42 Updated slices of the Pie Chart 

If you look at your chart (Fig.7.42 above) you’ll no doubt think those labels (numbers) are not 

exactly helpful. They’re small and are placed oddly in relation to the slices of the pie. So your last 

task is to format those numbers in relation to each of the slices so that they stand out and provide 

more information to the parents or guardians who are going to use the chart to compare their child’s 

grade with those of the rest of the class. 

Right click anywhere on the Pie chart (on one of the slices) and, in the 
Context Menu that pops up, select Format Data Labels… to bring up the Data 
Labels for Data Series ‘Students’ dialog box (Fig. 7.43) 

  

Fig. 7.43 Choosing Font Effects in the Data Labels dialog box 

First, click on the Font tab and select Comic Sans MS for the Font, Bold for 
the Style, and 15 for the Size of the font (Fig. 7.43)  
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Next, click on the Font Effects tab and, for the Font Color, select Orange 
Accent (or any color you like that’s dark, not light) and, for the Relief select 
Embossed (Fig. 7.44) 

 

Fig. 7.44 Selecting Font Effects for the Chart Labels. 

Now click on the Data Labels tab to bring up the Data Labels dialog (Fig. 7.45) 

 

Fig 7.45 Data Labels dialog 
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Remove the check mark/tick in the box next to Show value as number, then 
click to put a check mark/tick in the box next to Show value as percentage 
(the default format will use the % symbol), then click to put a check mark/tick 
in the box next to Show category; finally, click on the down arrow in the 
Placement box and select the menu item Outside 

Now click on OK, then click anywhere off the Pie chart 

Your chart should now look something like Fig. 7.46. 

 

Fig. 7.46 Finished chart ready to be copied and pasted 

Navigate to your disk drive > Work Files for LibreOffice > Data Files > 
Spreadsheet Documents and Save the Gradedata spreadsheet with the 
chart embedded in it 

Now you can copy the chart and paste it into the Mid Term Report. 

Click on any cell in the spreadsheet outside the border of the pie chart in 
order to deselect it; then click once on the Pie Chart to re-select it (you’ll see 
a set of 8 white handles around the border of the chart) 

Right click on the chart and, in the Context Menu, select Copy to copy the 
chart to the clipboard 

Switch back to the Writer Mid Term Report which is still open on your screen 

The Mid Term Report document should now be the active window on the screen. 

Click to position the cursor at the very beginning of the paragraph that reads 
“Please feel free to contact me…." and hit the Enter key to space down 
one line, then hit the up-arrow key on the keyboard to move the cursor back 
up one line 

Press Ctrl+v to paste the chart into the Mid Term Report document, use the 
mouse to drag the chart into position immediately above the paragraph that 
begins “Please feel free…”, then right click on the Chart and, in the Context 
Menu, select Properties 
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In the Properties dialog box click on the Borders Tab and, in the Line 
Arrangement section click on the icon to Set All Four Borders (Fig. 7.47) 
and click on OK 

 

Fig. 7.47 Selecting a border for the Chart in the Properties dialog box 

As it is, the letter now spills over onto a second page because of the chart. This is no problem 

if it cannot be avoided. Anyway, you’re going to add a paragraph to the letter in order to explain 

the purpose of the chart, so it’s inevitable that you’ll need a two-page document. 

Click to position the cursor immediately before the word “Please…” at the 
beginning of the paragraph following the chart, hit the Enter key to space down 
one line before you start typing in the following text: 

The chart above will help you see where your child stands with regard to 

the class as a whole. At Hodge Road Elementary we are all committed to 

helping every child achieve to the very best of her or his ability. To this end 

we strive to create a learning environment where each student can succeed. 

We cannot do this without the help of the parents and guardians of the 

children. So, I invite you all to meet with me so that we can further discuss 

your child’s academic performance. 

After you have typed in the above paragraph, hit the Return/Enter key once 
to space down below the chart 

Save (Ctrl+s) the Mid Term Report once again 

The final version of your Mid Term Report should look something like Fig. 7.48. 
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Fig. 7.47 Final version of the Mid Term Report 

Navigate to your disk drive > Work Files for LibreOffice > Data Files > 
Writer Documents folder and Save the Mid Term Report 

Saving and Printing the set of Mail Merged Mid Term Reports 

First you need to complete the merge of the Mid Term Report with the Roster 2020 database. 

In the File menu select Print…, and in the dialog box that pops up click on Yes 
to confirm that this is a form letter 

In the next dialog box, click to send the Output to a File and click on the radio 
button to Save as a single document, name the file Mid Term Report 
Merged Document, and Save it again 

If you wanted to print all the reports out on paper, make sure the printer is turned on and has 

paper in it, then click on File > Print… and proceed as you now know how. 
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LOOKING BACK 
This tutorial has involved you in activities that would normally be expected of a sophisticated 

computer user. This is not to say that you have therefore become an advanced user yourself. 

Actually, you are the best judge of that, because the term is relative anyway. As the old adage 

goes, people who think they know everything usually know next to nothing at all; and people who 

genuinely know a great deal generally recognize that they still have so much to learn. 

What is important is that you use the computing skills you have acquired. Only thus can they 

become second nature, a natural extension of your body and mind, making you more productive, 

and freeing you from preoccupation with the humdrum daily grind of classroom administration 

and control. 

 

LOOKING FORWARD 
The remaining lessons in this set of ESSENTIAL LibreOffice tutorials will provide you with the 

opportunity to learn more about the LibreOffice Base database and with the Impress presentation 

application. For the former you will learn how to work with an existing database for tasks such as 

searching and report-generation. For the Impress lessons you will prepare an outline and you will 

work with clip art and other graphics to create slide shows for presentations. You will also learn 

how to create an interactive PowerPoint presentation 

Having worked your way through the lessons to this point, you should be in a position to 

recognize the value of what you have learned, value both to you and to your students in the context 

of the K-12 classroom. 

 

SKILL CONSOLIDATION 
Complete these exercises to reinforce what you learned in Lesson 7. 

1. Imagine a scenario where you invite your students (as an assignment, perhaps) to prepare sets 

of questions for tests based on the material that you have covered in class. Each student types 

his or her questions into the database. You would check the database to make sure that each 

student had completed the assignment. Then you would print a copy of the full set of test 

questions for every student to use as a study guide. When the date for the test approaches you 

would simply select out those that you want to use, and print up the test using the pre-prepared 

test report format. 

  Individually or together with a team of your classmates, prepare a database to store sets of 

test questions. Make up a representative set of, say, 20 questions, and store them in the 

database. Prepare a test report format (form letter) to merge with the test question database. 

Use record selection rules to select ten out of the 20 questions. Print out the test (merge to 

printer). 

2. Get together with a group of your classmates or colleagues. Compile a list of suggestions for 

useful macros to use with Writer—macros like the SchoolAddress macro that you learned in 

this tutorial. For example, you could create a macro that types out your letterhead—address, 

telephone number, and the date, using different fonts and sizes. Create half a dozen macros 

from the best suggestions. 

3. Create a form letter to print a set of continuous index cards cataloging your collection of music. 

Use the Mailing Labels feature for this purpose. Set up a data source containing a sample set 

of data for at least 6 records. Each record should have at least 5 fields (CD Title, etc.). 
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4. Meet together with a group of your fellow students or colleagues, come up with a list of 

suggestions for useful form letters to be used in a school environment, share out the ideas 

among the group (a minimum of two each), and create the templates for the form letters. Each 

person in the group should save a complete set. 

5. Create a Labels form letter to print a set of individualized set of name tag stickers for a class 

of students to be worn on the first day of class so that everyone can get to know each other. 

Use the Mailing Labels feature for this purpose. Set up a data source containing a sample set 

of data for at least 25 records (use an existing class database, if you have one, or use the Roster 

2020 database that accompanies this tutorial). 


