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8 
MORE ON DATABASE USE 
Manipulating the Data in the Database 

 

LEARNING OUTCOMES 
Lesson 6 introduced you to the database concept in general, and to the Base database in particular. 

You learned how to plan a new database, how to set it up, how to add records, make changes to 

records, and delete records. You also learned how to save a database, and how to make backup 

copies. 

It is now time to start using those functions of the database that make it such a powerful tool 

for learning—for organizing data resulting from research, for helping you or your students to work 

on projects, for personalizing your interaction with students, and so forth. Some of the exercises 

cover aspects of database use—rules for finding and sorting records, for example, as well as 

querying a database and creating reports from subsets of data—which may be difficult for you to 

grasp. Forewarned is forearmed; put your thinking cap on! 

Lesson 8, then, after reviewing the basics, will introduce you to the following additional 

features of the Base database: 

• searching and querying a database 

• sorting records 

• creating reports 

• improving the report (making changes) 

• printing reports 

 

A caveat before you begin: You'll find it easiest to use the tutorial if you follow the directions 

carefully. On computers there are always other ways of doing things, but if you wander off on your 

own be sure you know your way back! 

 

8.1 GETTING STARTED 
Before you begin 

If you did not complete Lesson 1 of these tutorials, you will need to create a new folder to add to 

the set of folders in the Work Files for LibreOffice folder.  The new folder’s name is Data Files.  

Here are the steps to create this folder: 

Inside the Work Files for LibreOffice folder you should see three folders named Base Files, 

Impress Files, and Miscellaneous Files. You need to create a New, fourth, folder called Data Files. 

Here’s how you do this. 

In the Work Files for LibreOffice folder, right click in the white space below 
the list of the existing three folders then, in the drop-down menu (called a 
Context Menu) that pops up select New > Folder 
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The system immediately creates a new, as yet unnamed, folder. 

Type Data Files for the new folder’s name, and hit the Enter/Return key on 
the keyboard 

 

What are the some of the advantages that electronic databases have over manual record keeping 

systems such as filing cabinets, folders, rolodexes, and the like? By the time you completed 

Lessons 6 and 7, you must have had a clearer idea of what a database is. You can probably now 

come up with an answer to this question. Here are a couple of the reasons frequently forwarded 

for using a database. Can you find your response among them? 

• One can store huge amounts of data in a small amount of space (on a 2020 generation flash 

drive or, even better, a hard disk—not to mention the so-called Cloud1—you can store 

millions of database records); 

• One can easily manage all the data—view records, add new records, delete old records, or 

change existing records. 

You learned how to handle tasks such as these in Lesson 6. Here are some other reasons for 

using an electronic database. 

• One can quickly find anything one needs to know and get answers to questions about the 

data in the database. What is Larry Dorey’s phone number? 

• One can home in on a small subset of the data. Which students have a GPA below 2.0? 

• One can instruct the computer to arrange (sort) records, and thus organize the data any way 

one likes. I'd like a listing with everything sorted based on the student hobby field. That'll 

make it easy for me to identify students who have the same interests. 

• One can use the computer to create any number of reports for the purpose of supplying others 

with information pertaining to the data in the database. My principal, Yvonne Singer, wants 

a monthly report of student progress in Reading, Writing, Math and Science. 

The purpose of this tutorial is to help you learn how to use the Base database in these last four 

ways. By the end of the tutorial you will have the basic skills you need to become a power user of 

the database. Whether you ever can call yourself a skilled user will depend, of course, on whether 

or not you continue to use Base as a tool to support your professional work in the classroom. 

Practice makes perfect. If, after you complete this lesson, you never use a database again… Well, 

let’s not go there, OK? 

Make sure you have your Work Files for LibreOffice available on your 
computer, then Open LibreOffice and click on Open File or in the File menu 
select Open 

Base will display the Open dialog box. 

Navigate to your disk drive > Work Files for LibreOffice > Base Files folder 

 
1 The Cloud, as it’s called, is a name for so-called data farms or server farms which companies such as Apple and 

Microsoft (to name but two) have configured in such a way that they can handle massive—as in humongous—

amounts of data that are actually stored on a large number of computer storage facilities connected through a real-

time communication network such as the Internet. You don’t need to think about where your data is; you just use the 

Cloud to store copies of your data somewhere safe and off your own computer. 
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You are going to work first with a database similar to the one you created in Lesson 6, in order 

to standardize the directions that follow. The database, called Students 2020, has been prepared 

for you to use with this tutorial. 

In the Base Files folder open the Students 2020 database (NOT the Student 
Roster 2020 database) 

In the left frame of the Students 2020 Base window, click on the Forms icon, 
then, in the Forms section, double click to open the Students 2020 Form 

You should see the Forms View of the Students 2020 database, as illustrated in Fig. 8.1. 

 

Fig. 8.1 The Forms View of the Students 2020 database 

 

8.2 REVIEWING THE BASICS 
You may not have worked with databases a great deal prior to using these tutorials, so it will be a 

good idea to start by recapitulating what you learned in Lesson 6 by way of reinforcement. Then 

you can move on to learn about the new features of the Base database that are targeted for this 

tutorial. Let's start with terminology. 
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A database is a document which contains a set of records. Each record is made up of one or 

more fields, and each field may or may not contain entries. 

For example, a database of movie titles might have records for a few thousand movies. Each 

record will have fields for the movie title, the director, the producer, the star(s), and so on. A 

particular entry for the Movie Title field might be "Star Wars." 

Viewing the data in the database 

When you first open an existing database, it is generally best to open a Forms View of the database 

because you can easily view the contents of an entire record on the screen, thus showing you what 

all the records basically contain. 

In the Forms View, as you can see, the data for one complete record is shown in the Form. 

Notice the database navigation tools at the bottom of the Form window (Fig. 8.2). 

 

 

 

Fig. 8.2 Form Navigation tools in the Base database 

Look them over now to re-familiarize yourself with how they work. 

Now, File > Close the Students 2020 Form 

In the Database frame click on Tables and, in the Tables section, double 
click on Students 2020 Table to open it 

This Table view (Fig. 8.3) shows the records across the screen in rows and columns much like 

the Spreadsheets you learned to use in Lessons 4 and 5. 

 

Fig. 8.3 Viewing records in the Table view 

Adding a record to the database 

You can add a new record to the database any time you want. After you’ve added the record you 

can tell Base to sort everything into a specific order whenever you need to do so. You will learn 

how to do this in a later section of this tutorial (8.4 SORTING RECORDS). 

You are going to add some new records. It’s best to do this in the Forms view of the database. 

First 
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Record 
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Record 

New 
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Close the Students 2020 Table, in the Database frame select Forms, and 
double click to open the Students 2020 Form, then click on the New button in 
the toolbar at the bottom of the Form window (Fig. 8.4) 

  

Fig. 8.4 The New button in the Records Group of the Home Ribbon 

This will open up a set of empty fields for the new record (Fig. 8.5) 

 

Fig. 8.5 Entering data for a new record 
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Enter data for this new record, starting with the number 11 for the ID field (then 
12, etc.), pressing the Tab key after you type the data for each field, then add 
data for at least one other new record (two records in all) 

You can put any data in the new records you are adding because you’ll be deleting them in a 

bit. If no data is required for a particular field, you can skip a field (such as the last four fields), 

by simply pressing Tab without entering any data. 

Clearing a field in a record 

You cannot clear entries from a field that has been defined as requiring data of some kind in the 

field. If you try to clear data from these fields (in our database the First Name through the Home 

Contact fields, for example) you will get a warning from Base telling you that you cannot have a 

null value in these fields. 

Use the navigation tools (see Fig. 8.2 on page 285) to go back to the first of 
the records you added just now (Record 11) 

In the first of the records you added, in the Nick Name field, double click in 
the entry box (not on the field name) on the nick name to highlight the Nick 
Name entry, then press Ctrl+x on the keyboard to cut/delete the data in the 
Nick Name field 

Next go to the second of the records you added a moment ago (Next Record), 
click in the Nick Name field entry box, again highlight the nick name and 
press Ctrl+x on the keyboard to cut/delete the data from the field 

Notice that this deletes neither the field nor the record; it simply deletes (i.e. clears) the selected 

data in the field. The field is still there, so new data can be entered at any time. 

Deleting (clearing) a record, or a set of records 

Locate one of the records you just added (ID 11 or 12), then in the Form 
Navigation toolbar (Fig. 8.6), select Delete Record 

  

Fig. 8.6 Deleting a Record 

Base immediately displays a warning dialog box (Fig. 8.7) to tell you that if you go ahead you 

will permanently lose the data in the record. 

 

Fig. 8.7 Delete Record warning prompt 
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Click on Yes to delete the selected record 

This removes the record entirely. If you added more than one record, delete that, too. 

Changing the data in a field 

Suppose some data gets entered incorrectly—through misspelling or a typo. Let's say you needed 

to update a nickname in a student's record. To change it you would do the following. 

Locate the record in which you want to make the change (for this exercise 
select any record you like) 

Click in the entry box for any Nick Name field, double click on the nick name 
to select it, then change it to some other nick name in the same way you would 
in a word processor 

Simple. All the exercises in this section were by way of recapitulating what you learned in 

Lesson 6. Now let’s move on to learn some more advanced features of the Base database. 

 

8.3 SEARCHING AND QUERYING A DATABASE 
This is a powerful function of the Base database. You can find anything in the database if you 

know what to do. 

All you have to do is give Base any set of characters as the key for a search of the database, 

and the system will find that set of characters, if it exists, even if it is just a part (a subset) of a 

larger word or phrase. There are several ways you can do this. 

But first you need to open another, larger, database. 

Close the Students 2020 Form (you’ll be prompted whether you want to save 
the change you made to the nickname at the end of the previous exercise—
Fig. 8.8) 

 

Fig. 8.8 Prompt to save changes 

Click on No, then Close the Students 2020 database and, in the LibreOffice 
window, select Open File 
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On your disk drive navigate, if necessary, to your Work Files for LibreOffice 
> Base Files folder 

Double click to open the Birds database then, in the Database objects menu 
on the left side of the database window, click on Forms and, in the Forms 
section, double click on the Birds Form to open it (Fig. 8.9) 

 

Fig. 8.9 Birds Form 

Finding a single record using data from a specific field 

You often may need to locate and display the contents of one particular record, or set of records, 

based on data from one specific field. The Find function, which is in the Home Ribbon > Find 

Group, is the Base command to do this. It works much the same as when you use the Find 

command in the word processor, which you learned about in Lesson 2. 

Suppose, for example, you wanted to find the record for the bird with the Common Name 

Northern Oriole. Here is how you do this. 

In the Form Navigation toolbar at the bottom of the Form window, click on 
the Find Record tool—it looks like a spy glass (Fig. 8.10) 

  

Fig. 8.10 The Find Record tool in the Form Navigation toolbar 
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LibreOffice now displays the Record Search dialog box (Fig. 8.11). 

  

Fig. 8.11 The Record Search dialog box 

You need to indicate what data you want to be found in the Birds database by typing in a search 

string, which for our search will be Northern Oriole (Fig. 8.11 above). 

In the Search for box, type Northern Oriole or northern oriole—if you don’t 
check the “Match Case” box (Fig. 8.11 above), Base doesn't care whether you 
use upper or lowercase letters 

Before clicking on the Search button, you need to identify where you want to search (All 

Fields). You also need to indicate if you want to match the data in a whole field or part of a field 

(Anywhere in the field). 

Click to check the radio button next to All Fields (Anywhere in the Field is 
already selected by default) 

Now click on Search, and notice that the number 35 appears in the lower 
lefthand corner of the search window, indicating that the Northern Oriole is 
record #35 in the database (Fig. 8.11 above) 

Click on the Close button 

Northern Oriole is Record 

#35 in the Birds database 
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Base quickly locates the record containing the name "Northern Oriole" (Fig. 8.12). 

 

Fig. 8.12 Record 35 displayed in the Birds Form window 

As you see, Record 35 is displayed in the Birds Form window. The record(s) you find with a 

Find request are called the "found set." 

Of course, if you typed Northern Oriole incorrectly, Base would tell you that the search item 

was not found (Fig. 8.13). 

 

Fig. 8.13 Warning message after unsuccessful search of the database 
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Close the Birds Form (File > Close) 

Now, in the Birds > Database Objects frame click on the Tables view, then 
double click on Birds Table to see a columnar list of all the birds in the 
database 

In the Birds Table > Edit menu select Find Record… or hit Ctrl+f 1(Fig. 8.14) 

 

Fig. 8.14 The Birds Table window 

LibreOffice displays the Record Search dialog box (Fig. 8.15), prompting you to fill in the 

relevant search criteria. 

  

Fig. 8.15 The Record Search dialog box 

 
1 Ctrl+f is the shortcut to the Record Search dialog box.  You can also use the Form Navigation toolbar for this 

purpose, as we will do later in the tutorial. 
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You need to indicate what data you want to be found in the Birds database by typing in a search 

string (which for our search will be Northern Oriole). 

In the Search for box once again type Northern Oriole (or northern oriole—
if you don’t check the “Match Case” box, Base doesn't care whether you use 
upper or lowercase letters) 

Before clicking on the Search button, you need to identify where you want to search (All 

Fields). You also need to indicate if you want to match the data in a whole field or part of a field. 

The radio button next to All Fields should be checked/ticked and that the 
Search tool looks anywhere in the field (Fig. 8.15 previous page) 

Now click on Search and notice that the number 35 appears in the lower left-
hand corner of the search window, indicating that the Northern Oriole is 
record #35 in the database 

Click on Close to end the search 

Recall that the record(s) you find with a Find request are called the "found set". As you see, 

Base quickly locates the record containing the name "Northern Oriole." The record is displayed in 

the Birds Table window along with a blue pointer indicating its location in the database (Fig. 8.16). 

  

Fig. 8.16 Pointer indicating location of the Found record 

Now Close the Birds Table (File > Close) 

Finding two or more records based on data from a single field 

Next, let’s search on criteria which will find more than one record. You want to find any bird with 

the primary color (Color1) that has any shade of black in its plumage. 

If necessary, in the Database Objects frame on the left side of the window 
select the Tables View 

Double click on Birds Table to see a list of all the birds in the database, then 
click to put the cursor anywhere in the Color1 column 
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Hit Ctrl+f on the keyboard 

This once again brings up the Record Search dialog box (Fig. 8.17). 

  

Fig. 8.17 Results of the search 

In the Search for section make sure the radio button next to Text is selected, 
and type the word black (if it doesn’t already have “black” there) 

In the Where to search section make sure the radio button next to Single 
field: is selected and that Color 1 is already in the data entry box 

In the Settings > Position: box select the option for entire field to ensure that 
only those birds in the Color 1 field have plumage that is simply black 

Click on Search  

The search finds the first of 9 records where a bird in the Color1 field of the database has the 

color “black” (not “bluish black” or “blackish”) in its plumage, in this case record 7 (Fig. 8.17). 

If necessary, grab hold of the Title Bar of the Record Search dialog box (see 
Fig. 8.17 above) and drag the dialog box out of the way so that you can see 
the set of records in the Birds Table 

Notice that the contents of the Color 1 field in Record 4 is highlighted with a red border. 

Title Bar 
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To see the data in the next record that has the Color1 > Black, click on Search 
again, and so on—keep count of how many records with the Color 1 > black 
anywhere in its entry 

When you’ve finished counting, click on the Close button 

Did you count 9 records of birds with the Color1 black in the plumage? To see a listing of just 

those 9 records that result from a search such as this, you must use a filter. 

Using the AutoFilter 

In general, filtering is best done in the Table view of the database. The exercise that follows will 

use LibreOffice’s AutoFilter tool to select the set of birds whose habitat is “marshes.”  

In the Birds table, if necessary, scroll to the right to locate the Habitat column 
(Fig. 8.18) 

 

Fig. 8.18 The Birds Table view showing the Habitat column 

Now, in the Habitat column, scroll to the top of the column—to the first 
record—click on the first “Marshes” entry you see (there’s one in Record 6) 
then, in the Data menu select the AutoFilter tool (Fig. 8. 19) 

 

Fig. 8.19 Using the AutoFilter tool to find all the birds that have a Marshes Habitat 
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This tells Base that you want to filter by selection the set of birds that live among marshes. 

Base now displays a list of 15 birds in the database that live in marshes (Fig. 8.20). 

 

Fig. 8.20 The found set of filtered records 

To go back to viewing all the records in the database, in the Data menu 
select Reset Filter/Sort 

Using the Standard Filter 

You also can filter records using LibreOffice’s Standard Filter. You need this, for example, if you 

need to select a set of records based on more than one criterion. 

Let’s say you want to find all the records in which the birds have either the color “black” or a 

combination of “black” and some other color in their plumage. This involves filtering based on 

both the Color 1 and Color 2 fields. 

In the Data menu, click on Standard Filter… (Fig. 8.21) 

  

Fig. 8.21 The Standard Filter tool 
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When you click on the Standard Filter tool, LibreOffice presents the Standard Filter dialog 

box, in which you have the opportunity to set 2 or more criteria for the filter (Fig. 8.22). 

  

Fig. 8.22 The settings for the search in the Standard Filter dialog box 

In the first Field Name box, click on the down arrow to show all the fields in 
the Birds database and click on Color 1, leave the equals sign (=) in the 
Condition box, then in the Value box type the key word black (all lowercase 
letters—after a few seconds the quotes are added by the system) 

In the second Field Name box, click on the down arrow to show all the fields 
in the database and click on Color 2, leave the equals sign (=) in the 
Condition box, then once again in the Value box type the key word black (all 
lowercase letters—after a few seconds the quotes are added by the system) 

Now go back to the Operator box to the left of the Color2 Field name and 
select OR for the operator (see Fig. 8.22 above), and finally click on OK to 
accept the query  

These criteria that you have selected should find all the database records in which the birds 

have either the color “black” or a combination of “black” and some other color in their plumage, 

based on the Color 1 and Color 2 fields. Let’s see. 

In the Standard Filter dialog box, click on OK 

Now look at the set of records that the filter found (Fig. 8.23). 

 

Fig. 8.23 Result of a Standard Filter of the Birds database 
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Check out the Color1 and Color 2 fields in the Found Set of 14 birds. One or other of them has 

the color ‘black’ somewhere in their plumage. 

This might seem like a silly exercise. Maybe it wouldn’t take you long to find the 14 records 

out of the 50 records in the database. Wouldn’t take you a minute or two to do that just by scrolling 

and counting, right? But suppose you have 500 records, or 5000 records, or, as is common in 

school districts in large cities, 500,000 records or more. The larger the database, the more you need 

tools such as these filter tools—and the Sort tools in the next section—to help you quickly find the 

data you need. 

In the Data menu select again Reset Filter/Sort to list all the records in the 
database before proceeding to the next section in the tutorial 

 

8.4 SORTING RECORDS 
The three major advantages of an electronic, digital data storage system over a manual, paper-

based filing system are these: 

1. Enhanced Organizational flexibility: Digital, electronically stored data with its easy 

ability to quickly access the data you need in any of multiple formats and the easy ability 

to organize it in any of multiple ways, provides more or less instant organizational 

flexibility—using filtering and sorting, for example—which helps you cope with the 

inevitable complexity that increases as the sheer amount of data grows. 

2. Saved Space: Digital, electronically stored data saves space—physical space, that is. You 

don’t need a filing cabinet, or oodles of filing cabinets in a storage room, or, for some 

companies, a whole building for a data repository. For teachers, like you and me, all we 

need is a few gigabytes of storage on a disk drive, which we can carry on a car key chain 

or in a pocket (provided we’re careful to back up all the data on another computer in the 

office or at home). 

3. Saved Time: Digital, electronically stored data increases the speed of data access and thus 

saves time. 

When we use old-fashioned filing cabinets to store data, we usually come up with some kind 

of organization. So, we put labels on the drawers in the cabinets and labels on the folders inside 

the drawers. This organization is often based on numeric or alphabetic sequencing. The purpose, 

of course, is to enable us to quickly find what we have stored in the appropriate folder in the 

appropriate drawer. 

This is a good system as long as we have no cause to frequently change the organization we 

have set up. It also assumes that space and time are not at a premium in our day to day operations. 

Unfortunately, coping with change, making good use of space, and saving time are factors critical 

to our productivity. So, we should welcome any system which helps us cope with change and 

optimizes our use of space and time. 

Today, using state of the art technology, we can electronically store the equivalent of the 

Library of Congress in a shoe box. And we can now access any specific item in that "box" in a few 

thousandths of a second. What is more, software such as Base makes it possible for you to organize 

that data more or less on the fly by sorting it any which way you want—provided you organize the 

database in ways that allow you to do so. 

Remember: a system is only as good as the people who own it—the people who plan it, design 

it, build it and maintain it. 
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Sorting on a single field 

Take, for example, the Birds database that is on your desktop at this time. As you can see, the 

names of the birds (in the Common Name field) are not sorted in any particular order. In fact, as 

it happens, the Birds database that accompanies the LibreOffice Work Files is sorted based on the 

ID field (which is the Primary Key for the relational database). 

So the ordering is numerical rather than alphabetical. It would therefore be time consuming, if 

not well-nigh impossible—especially if the database were very large—for you to visually scan the 

database to find the record for a particular bird. 

This is why Base makes available the Find Record, Filter Records, and Sort Records functions 

accessible in the Form Navigation toolbar. We’ve looked at the Find Record and Filter Records 

functions. Now let’s check out the Sort Records function. 

What if you wanted to print out a report listing all the birds in alphabetical order by name of 

bird? You would have to begin by organizing the records alphabetically on the bird names. 

Fortunately, Base has a set of Sort tools that enable you to complete this operation with the greatest 

of ease. Fig. 8.24 illustrates where, in the Form Navigation toolbar, you will find this set of Sort 

tools. 

 

Fig. 8.24 The Base Sort tools in the Table Data toolbar 

You can best see the results of a Sort if you are in the Table view of the database, which is the 

view you should have on your screen from the previous exercise. Notice, too, that the records are 

not sorted after the previous exercise 

Click to put the cursor in any cell in the Common Name field, then click on the 
Sort Ascending button (Fig. 8.25) 

 

Fig. 8.25 The Sort Ascending tool 
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Immediately Base sorts the records alphabetically on the Common Name field, with the 

American Bittern at the top of the list, and so on. Notice that, when sorting on a single field like 

this, the entire record is sorted, based on that single field. So, all the data in a particular record is 

kept together in the database, just as it should be. 

There are three basic sorting options depending on the type of data in the field you are using 

as the basis, or key, for the sort: 
• Alphabetical: If your sort request is based on a Text field such as Common Name or Location 

Sighted, the sort will be alphabetical and can be either Ascending (A to Z) or Descending 

(Z to A). 

• Numerical: If you are sorting on a Number field such as the Count field, the sort will be 

numerical and you again would be able to sort in Ascending (low number to high number) 

or Descending (high number to low number) order. 

• Chronological: Finally, if you are sorting on a Date field such as Date Sighted, the sort will 

be chronological, and you would be able to sort in Ascending (chronological) or Descending 

(reverse chronological) order. 

Let’s do another quick sort for practice—which, as we know so well, makes perfect. 

Click to position the cursor anywhere in the ID column, then click on the Sort 
Ascending tool (see Fig. 8.25 previous page) 

Immediately LibreOffice sorts the data based on the ID field, with the value 1 at the top and 

the value 50 at the bottom—and the data that goes with each ID is, of course, sorted along with it. 

As you see, basic sorting of a database is simple. 

 

8.5 CREATING QUERIES AND REPORTS 
A word about the Base database reporting facility 

Reports are what we submit to our bosses in response to information that they need. It doesn’t 

matter to anyone why they need the report. All that matters is that they must have it. So we 

(teachers and others in the chain of command) must produce it. Period. 

Base makes it easy to produce reports provided you have gathered into a database any and all 

information needed for a report. Let us assume that you have done that. What, then, are the criteria 

for a good report? 

• Planning is still an important prerequisite for creating good reports. No matter how tempting 

it might be, always resist creating a report without first thinking and mapping out what you 

want as the finished version of a report. 

• Changes you make to data fields for the report do not affect the data in the database. So you 

don't have to worry about losing data, or messing up the database when you create reports. 

• You can create reports that contain just a few fields from a selected set of records by using 

the search criteria techniques that you already learned about in this lesson. For instance, you 

could use the Birds database to print a report listing just the name, color, and count of birds 

that were seen in your neighborhood. Shortly you will practice something along these lines. 

• You can create numerous layouts or reports based on the data in a database, just as you can 

create numerous different tables or forms, each containing its own set of data from the 

database as a whole. Each report can be different—different fields, different sets of data 

within fields, and so on—and you can store them all along with the database. 

In the next sections you will continue to work with the Birds database. 
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Initial definition of the layout or report 

You are going to create a layout, or report, which will list all members of the Duck family sighted 

during the reporting period covered by the database. The fields in the report will include the 

Common Name, Family, Date Sighted and Count fields.  

Bear in mind that most databases have many fields. If there are more field names in a report 

layout than can fit across the screen or page, the names simply wrap around, creating two or more 

lines, if necessary, in the top section (the Header) of the layout. 

This can make for untidy, not to say confusing, reports. The columnar report you are about to 

work with will not have this problem because you will be using only a small selection of the fields 

in the database (just 4 to be exact), but it is good to be aware of the problem should the occasion 

arise where you want to create a report that uses many fields. 

You can get around this problem is various ways, the simplest of which is to change the font 

to one which requires less space, or reduce the size of the font you want to use, or lay out the fields 

in some format other than like a Table or Spreadsheet). 

You might also consider whether you really need all the fields that you have selected for the 

report. Often, simpler is better. Simple reports are more likely to be read, and if they’re read they’re 

more likely to make the desired impact. 

Creating a Query 

You need to start by creating a Query to tell the Birds database exactly which data you want to 

use for the Report. You’re going to select only the Duck family of birds for the Report. Once you 

have created the Query, it will be a simple matter to create the Report. 

Here are the steps to create the Query. You’re going to work with the Birds database, so keep 

that file open on your screen. 

Close (File > Close) the Birds Table (NOT the Birds database, which you’re 
going to work with now) 

In the Birds Database frame (at left), click on the Queries icon then, in the 
Tasks section, click on Use Wizard to Create Query… (Fig. 8.26) 

  

Fig. 8.26 Using a Wizard to create a Query 
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LibreOffice now presents the familiar Query Wizard window, asking you (Step 1) to 

select the fields (Field Selection) that will be involved in the Query (Fig. 8.27) 

  

Fig. 8.27 Step 1 of the Query Wizard 

Notice that the fields are all coming from the Table: Birds Table in the Birds Base database. 

Double click, one after the other, on the Common Name, Family, Date 
Sighted, and Count fields to move them across to the Fields in the Query 
box (Fig. 8.28), then click on the Next > button 

 

Fig. 8.28 Selecting the required fields for the Query 
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The next step in the Wizard, Step 2, asks you if you want to sort the data.  There’s no need to 

do this—the query will take care of selecting out the data you need. 

Click on Next > to proceed to Step 3 

In Step 3 you’re going to Select the search conditions for the Query (Fig. 8.29). 

 

Fig. 8.29 Selecting the search conditions for the Query 

In Step 1 you selected the Fields for the Query, and now you must select a subset from the 

family field for the Report you will build in the next exercise, a report which is based on the 

Query you are creating right now. This is where your logic skills will come in handy. 

Click on the down arrow in the Fields box Fig. 8.29 above) and, in the drop 
down menu of Fields, select Birds Table.Family, leave the Condition as is 
equal to and, in the Value box, type the entry Duck (we want every type of 
Duck—and only Ducks—in our report), then click on Next> 

In the next step of the Wizard—Step 4 (Detail or summary)—Detailed query 
(Show all records of the query) is the default (Fig. 8.30) 

 

Fig. 8.30 Going with the default value for Step 4 
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Detailed query… is what you want, so click on Next > again 

Steps 5 and 6 are greyed out because you don’t need them for this query, 
nor do you need to change the field names in Step 7. Aliases, so click on 
Next > once again 

Step 8 presents an overview of what should go into the Query that is going to determine the 

contents of the upcoming Report. 

In this last step of the Wizard, change the Name of the Query to 
Query_Count of Ducks (Fig. 8.31) 

 

Fig. 8.31 Overview of the Query 

For How do you want to proceed after creating the query? leave the default to 
Display Query so that you can check that the Query has successfully 
produced the Found Set of data you want for the report (Fig. 8.31 above) 

While you’re still on Step 8, read through the Overview section to see if what 
you have done in the previous steps makes sense (Fig. 8.31 above) 

When you’re ready, click on Finish 

Check 

this out 
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Base quickly uses the Query to produce a display of the Found Set (Fig. 8. 32) 

 

Fig. 8.32 The Found Set for the Query Count of Ducks  

What you see on your screen should be the same as in Fig. 8.32 above—9 records, all of 

them from the Duck family, showing their Common Name, Date Sighted, and Count. Now you’re 

ready to go ahead and create the Report, which will be called Count of Ducks Sighted. 

Creating a Report based on the Query1 

Close the Query_Count of Ducks window and, in the Birds database 
window, in the Database frame (at left) click on the Reports icon then, in the 
Tasks section, click on Use Wizard to Create Report… (Fig. 8.33) 

  

Fig. 8.33 Selecting the Wizard to create the report 

 
1 TheFrugalComputerGuy’s video: https://www.youtube.com/watch?v=_7ZHRIQfV-s does an excellent job of 

explaining how to create savable reports that include headers and other layout features. You should watch it! 

https://www.youtube.com/watch?v=_7ZHRIQfV-s
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This will bring up the Report Wizard dialog box (Fig. 8.34). 

  

Fig. 8.34 The Report Wizard dialog box 

In Step 1 of the Report Wizard, in the Tables or Queries data box, leave the 
default Query: Query_Count of Ducks as the source for the report’s data (Fig. 
8.34 above) 

Then, in the list of Available fields, click on the double arrow (again see Fig. 
8.34 above) to move all four fields to the Fields in report box (Fig. 8.34 
above), then click on Next > 

  

Fig. 8.35 Selecting the Fields for the report 
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This brings up Step 2 of the Report Wizard, where you are asked to decide how you 

want to label the fields for the report (Fig. 8.36) 

 

Fig. 8.36 Step 2 of the Report Wizard 

The labels are fine as they are, so click on Next > 

In Step 3 of the Report Wizard you are asked if you want to group the data in the report using 

levels, which could be useful if you wanted, say, to group birds according to the year they were 

sighted and within each year group at a lower level according to the location where the birds were 

sighted and so forth. But there’s no need for that in this report. 

Click on Next > to proceed to Step 4 

In Step 4 you are asked if you want to Sort the data in the database prior to producing the 

report, but you already sorted the data in an earlier exercise based on the ID field. 

So, click on Next > to proceed to Step 5 of the Report Wizard, where you are 
asked to Choose a layout for the data in the Report (Fig. 8.37) 

  

Fig. 8.37 Step 5 of the Report Wizard 

,,,,,,, 
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Tabular is the default layout option and works well for this report, so leave that as is. 

The four fields in the report can fit easily across the page using Portrait 
Orientation, so click on the radio button next to Portrait Fig. 8.37 previous 
page), then click on Next > to proceed to Step 6—Create report (Fig. 8.38) 

 

Fig. 8.38 Step 6 of the Report Wizard (Create Report) 

In the Title of report data entry box type the title: Report_Count of Ducks 

You want the report to be Dynamic so that the report will reflect changes to 
the data at a later date should the data in the database change, which is likely 
over time, so check/tick the radio button next to Dynamic (see Fig. 8.38 
above) 

You also want to have Base create the report after you click on Finish, so 
check the radio button next to Create report now (Fig. 8.38 above again), 
then click on Finish 

On the screen you should now see a rough and ready version of the report with column 

headers and, underneath them, the data for each column from the Found Set of Duck records 

(Fig. 8.39). 

 

Fig. 8.39 Rough and ready version of the Count of Ducks report 
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Notice (Fig. 8.39 above) that the report is initially read-only—you can’t actually interact 

with it or make any changes to it as is, unless you click on the Edit Document button (Fig.8.39 

above).  

Click on Edit Document now to bring up the editable version of the Count of 
Ducks Sighted report (Fig. 8.40) 

  

Fig. 8.40 Editable version of the Count of Ducks Sighted report 

Working with this “editable” version of the report is OK if all you want to do is make some 

changes and then print out the edited report before moving on to other work. Thing is, doing it 

this way you can’t actually save your edits for future use.  The steps that follow will show you 

how to use the Base Report Builder to edit a report and save your changes; thus, your efforts will 

not be wasted. First you need to close this “first pass” at the report. 

Go to File > Close 

Using the Base Report Builder  

The Bird database should still be open on your screen, with the Reports Object selected in the 

Database Objects frame on the left, and the Report_Count of Ducks report listed in the Reports 

section of the Birds database window. 

Your goal now is to work on the Report_Count of Ducks report till you’ve created something 

like the version in Fig. 8.41. Tips for doing this follow Fig. 8.41. 

 

Fig. 8.41 The final version of the Count of Ducks Sighted Report 

Titles (aka Headers) will go up here 

Data in these 3 columns will be centered on the column 

title 
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Here are some tips to help you along the way. But bear in mind that trial and error is the only 

way to end up with a final satisfactory outcome, so be patient and don’t give up until you have 

something resembling the report in Fig. 8.41 above. 

First, right click on the report titled Report_Count of Ducks and, in the 
Context Menu, select the option to Edit the report (Fig. 8.42) 

 

Fig. 8.42 Opening the report for Editing purposes 

This brings up the Base Report Builder dialog box (Fig. 8.43). 

 

Fig. 8.43 The LibreOffice Base: Report Builder 

Let’s start with the Column Headers, which move independently of the data that is listed in the 

column. You’re going to spread them out so that they are arranged evenly across the page.  Let’s 

start with the Count header. 

The width of the page extends from edge 

to edge as defined by the red arrows 
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Click on the Count header to bring up the square white handles that tell you 
it’s selected (Fig. 8.44) 

 

Fig. 8.44 The handles around the Count column header 

Use the mouse to grab the handle immediately to the left of the Count header 
and drag it to the right about ½” (Fig. 8.45) 

 

Fig. 8.45 The Count header dragged an inch to the right 

Now you need to move the Count Detail (the set of data) in the Count column so that it’s 

centered under the Count header. 

Click on the Count Detail box to bring up the handles (Fig.8.46), use the mouse 
to grab the handle immediately to the left of the Count Detail box and drag it to 
the right to more or less center it under the Count header (Fig. 8.46) 

 

Fig. 8.46 Adjusting the position of the Detail data in the Count column 

Now you need to right align the numeric Detail data in the Count column. 

Click to select the set of numbers in the Count column (handles are around it) 
then click on the right align icon in the Formatting toolbar 

Save the Report_Count of Ducks (Ctrl+s), then check out your work by 
clicking on the Execute Report icon in the Standard toolbar (Fig. 8.47 on the 
next page) 

Use the mouse to grab the handles 

immediately to the left of the Count header 

and drag them to the right about 1” 

Count detail 

box 

Right Align 

icon 
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Fig. 8.47 The Execute Report tool on the Standard Formatting toolbar 

Fig. 8.48 shows how the Count Column in the Report_Count of Ducks should now look 

 

Fig. 8.48 The Count data set right aligned under the Count column header 

Close the Execute Report window (File > Close) then use what you just 
learned to slide the Date Sighted column header about ¾” to the right and 
slide the Date Sighted Detail data box to the right till it is more or less 
centered under the Date Sighted column header (click on the Execute 
Report icon as you work to make sure things are looking the way you want) 

Don’t worry if it seems tricky aligning things up. It’s really a matter of trial and error.  Make 

adjustments till you get it right. Remember that text is left justified by default, so the data will align 

with the left side of the box. 

Slide the Family column header about ¾” to the right and then slide the data 
in the column to the right till it is centered under the Family column header 
(click on the Execute Report icon as you work to check that things are looking 
the way you want) 

The Common Name column doesn’t need to be adjusted at all. 

Save Report_Count of Ducks (Ctrl+s), then check out your work by clicking 
on the Execute Report icon  

When you are satisfied with the look of your report it should look something like Fig. 8.49. 

 

Fig. 8.49 Final look of the report’s design 

Click on File > Close to close the Execute Report window and go to File > 
Save to save the Report_Count of Ducks report 
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Creating a Report Header 

The last task is to create the report header, where you are going to insert a report Title and the 

Date (scroll back to Fig. 8.41 on page 309). To insert a Header you’re going to make a copy of 

the Report_Count of Ducks and give the copy a new name. 

With the Reports object selected in the Database frame (on the left of the 
Birds window), right click on Report_Count of Ducks and, in the Context 
Menu that pops up, select Copy 

Now right click in the white space below the Report_Count of Ducks and, 
in the Context Menu, select Paste 

When you select Paste in the menu, a dialog box pops up (Fig. 8.50) which prompts you to 

change the report name; change it to Report_Count of Ducks Header then click on OK 

 

Fig. 8.50 Creating the new Report_Count of Ducks Header report 

Go to File > Save to save the new report, then right click on Report_Count 
of Ducks Header report and, in the Context Menu (Fig. 8.51), select Edit… 

  

Fig. 8.51 Select Edit… in the Report Context menu 
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The Report Builder for Report_Count of Ducks Header opens for you to add the Header lines 

to the report. To do this you will use the Label tool (Fig. 8.52). 

 

Fig. 8.52 The Report Builder waiting for you to add the header details 

Click on the Label tool (see Fig. 8.52 above) and use the mouse to draw a 
Label Box centered in the Page Header area, spanning from the ¾” 
hashmark on the ruler bar to the 6” hash mark (Fig. 8.53) 

 

Fig. 8.53 Draw a Label Box in the Page Header area for the report Header  

Double click inside the Label Box to bring up the Properties dialog box (Fig. 
8.54) 

 

Fig. 8.54 Using the Properties dialog box to enter the text and format for the report Header 

The Header will be centered 

in a Label Box and the font 

will be Arial, Bold, 32 pt 

Label tool 

¾” 6” 

Properties dialog box 

Click on the ellipses 

(…) to bring up the 

Character Settings 

dialog box 
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Refer to Fig. 8.54 above as you fill in the various items in the Properties dialog box. 

In the Name data box type the name: Header (Fig. 8.54 above) 

In the Label data box type the name: Count of Ducks Sighted (Fig. 8.54) 

For the Font settings, click on the ellipses (…) to bring up the Character 
Settings dialog box (Fig. 8.55) 

 

Fig. 8.55 The Character Settings dialog box 

In the Character Settings dialog box, change the Font to Arial, the Style to 
Bold and the Size to 32 pt, click on OK then Save the Report_Count of 
Ducks Header 

Click on the Execute Report tool to see how the report looks at this stage 

Inserting the Date into the Report Header 

In the Insert menu select Date and Time… to bring up the Date and Time dialog 
box (Fig. 8.56) 

 

Fig. 8.56 The Date and Time dialog box 
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Click to put a check mark/tick inside the Include Date box and in the 
Format: column click on the date format that looks like Monday, Oct 12, 
2020 

More space needs to be allowed in the Date box, so grab one of the handles 
on the right hand side of the Date box and slide the mouse to the right to 
stretch the Date box a couple of inches to allow for longer dates 

The Date also needs to be centered, so with the handles still around the 
Date box, in the Formatting toolbar click on the Centered icon 

Click on the Execute Report icon to check out the look of the report after you 
are satisfied with your changes to these Headers 

Save the report one more time, then Save the Birds database 

If all went well, your report should now look much like that illustrated in Fig. 8.57. 

 

Fig. 8.57 The final version of the Report_Count of Ducks Header report 

There are many more changes you could make to the report, such as adding graphics (maybe 

a picture of some ducks on a pond, for example) or background colors, and the like. If the report 

spanned several pages, you would almost certainly want to include page numbers (Insert > 

Fields > Page Number, which you learned about in Lesson 2). 

This is just an introduction to the topic of creating queries and reports. It is now up to you to 

extend your skills beyond these tutorials. Practice makes perfect, as you know so well. 

 

8.6 PRINTING REPORTS 
Once you have prepared the new report, it is a straightforward process to print the report. The 

command to do this is the same as you have used to print any other documents from within 

LibreOffice, whether you have been working in Writer or the Calc. 

If you are able to print the report, go to File > Print to print the Report_Count 
of Ducks Sighted Header report 

Remove the report from the printer and take a closer look at its contents. Notice that the only 

records in the report are those relating to ducks in the Family field. These are just a small subset 

of records drawn from the larger Birds database.  
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LOOKING BACK 
The Base database is a sophisticated tool for managing data. The key to success, as in so many 

activities, is PLANNING. Computers are wonderful tools to assist us in our professional lives, but 

only if we bring our intelligence to bear. The more skillful the user, the more powerful the impact 

of the computer on our professional and non-professional productivity.  

You practiced three important skills of database management in this tutorial: 

1. You learned how to search and query a database so that, no matter how large it might be, 

you could easily and quickly get the answers to any questions you might have. Getting 

answers to questions, research and so forth, is what electronic databases are all about. 

2. You learned how to sort a database and select out subsets of records. 

3. You learned how to create and print new layouts or reports based on the data in a database. 

Perhaps you have already learned about the value of database management systems such as 

Base in the educational process. Databases are the electronic storage bins for knowledge. Today 

they are both local and global in scope. More and more data is becoming available for on-line 

research. In time, maybe 50 years from now, maybe less, all knowledge will be accessible 

electronically. In the meantime, as teachers we should become aware of just what is available to 

our students and do what we can to educate them to take advantage of information services of all 

kinds. 

The role of teachers is changing. We are no longer the source of all knowledge. Rather, we are 

"knowledge brokers," intermediaries between our students and the source of the data they need so 

that they can "grow in wisdom and knowledge." As someone has observed, "Teachers should move 

away from being sages on the stage, and become, instead, the guides at the side." 

 

LOOKING FORWARD 
There is more to learn about the Base database. 

It is beyond the scope of this book to cover all of the features of the software. However you have 

certainly learned the fundamentals and have the tools now to make a database work for you and 

for your students. The exercises that follow in the SKILL CONSOLIDATION section will help 

you reinforce the knowledge you have gained. 

"Practice makes perfect" is as true of computer use as it is of any other skill-based activity like 

playing tennis or baking a cake. So is that other saying: "Use it, or lose it." You can probably 

identify many examples from your own experience where skills you were once proud to have 

mastered have become 'rusty' for lack of use. Likewise, you will quickly forget what you are 

learning in these tutorials unless you resolve to continue to apply the lessons learned on a regular 

basis, either for your own work or in the context of the classroom. 

The best teachers will use all the help they can get. The purpose of these tutorials continues to 

be to sharpen your skills in the use of one of the most powerful classroom tools yet devised—the 

electronic computer. You are to be congratulated for having persevered thus far. The remaining 

two tutorials will help you integrate the skills you have learned, and hopefully spur you on to a 

commitment to continue to incorporate the computer into your professional life both for your own 

sake and for that of your students. 

 

SKILL CONSOLIDATION 
Complete as many of these exercises as you can to reinforce what you learned in Lesson 8. 
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1. Work with a group of your colleagues or classmates to specify and create a series of reports to 

accompany a database of student data such as the Roster Template database that you created 

in Lesson 6. Save the template with the set of reports. 

2. From the Work Files for LibreOffice > Data Files > Base Documents folder on your disk drive, 

open the Roster 2020 database onto the Desktop. 

• Add a record 

• Change the address and phone # in an existing field 

• Arrange the records chronologically on date of birth 

3. Create a new database (do not use a database you already created) on any topic of your 

choosing. 

• Design the fields (at least 10) to be included in the database 

• Save the empty database document 

• Add at least 20 records 

• Save the database document again 

• Prepare a report using just 5 of the fields in the database 

• Save the database with the report and send the database to your professor as an attachment 

in email 

4. Open the Birds database (in the Work Files for LibreOffice > Base Files folder) onto the 

Desktop. 

• Find all the birds that have blue, grey, green, or olive in their Color1 plumage 

• Arrange (Sort) the birds in descending order (reverse alphabetical order—from Z to A)—the 

Birds, not the Colors! 

• Prepare a report using just the following 5 fields in the database: Common Name, Family, 

Color1, Habitat, Count 

• Save the Birds database with the report and send the database to your professor as an 

attachment in email 


